Bug 5314 (int-133681)

Summary: Easy to enter ~ ^ ' ` " symbols with 3rd row of special character view
Product: [Maemo Official Platform] Desktop platform Reporter: Lucas Maneos <maemo>
Component: Input method frameworkAssignee: Joaquim Rocha <jrocha>
Status: VERIFIED FIXED QA Contact: input-method-framework-bugs
Severity: normal    
Priority: Low CC: andrea, andrei.mirestean, andre_klapper, anidel, apolkosnik, archebyte, dieter, dneary, hald, jibreil, kristopherkantoraccounts, kyle, nokia, quim.gil, tim, tony, toojays, v2px, ymbrads+maemobugs
Version: 5.0/(1.2009.42-11)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: N900   
OS: Maemo   

Description Lucas Maneos (reporter) 2009-10-12 11:04:36 UTC
SOFTWARE VERSION:
1.2009.41.-10

STEPS TO REPRODUCE THE PROBLEM:
1. Open xterm (or any app/field that expects keyboard input).  
2. Press Ctrl+Fn
3. Press any character on the third row.

Example: I was trying to enter a "~" character to terminate a stuck (due to IP
address change) ssh session.

EXPECTED OUTCOME:
Selected character is entered.

ACTUAL OUTCOME:
Selected character is highlighted, but that's it.  The character isn't entered
and the palette remains on screen until one taps on a characted on one of the
other rows or the blurred area behind it.

REPRODUCIBILITY:
Always.
Comment 1 Daniel Martin Yerga 2009-10-12 12:11:12 UTC
AFAIK, this is a *feature* ;-)
You need press some key in the keyboard after pressing the special character.
For example, for "~", press space.
Comment 2 Lucas Maneos (reporter) 2009-10-12 12:30:19 UTC
(In reply to comment #1)
> For example, for "~", press space.

Ah, that works, thanks :-)
Comment 3 Andre Klapper maemo.org 2009-10-13 22:07:44 UTC
This is the 5th time I see a report by somebody not understanding this
interface, hence I'd start calling it a bug. :-P
Comment 4 Lucas Maneos (reporter) 2009-10-14 11:06:13 UTC
To be fair, it's documented - I just hadn't found TFM to R at the time
(assuming it would be PDF as before I tried to open it directly from the PDF
reader which showed an empty "User Guides" folder).

But as long as we're keeping this open, a couple of suggestions to make the
deadkey row more obvious would be to make it either the first or last row, and
give it a slightly different foreground and/or background colour.
Comment 5 Lucas Maneos (reporter) 2009-10-14 14:04:20 UTC
*** Bug 5433 has been marked as a duplicate of this bug. ***
Comment 6 Quim Gil nokia 2009-10-15 08:45:39 UTC
Yes, we will try to fix this problem in Fremantle. Setting target milestone by
now.
Comment 7 Quim Gil nokia 2009-10-16 12:09:26 UTC
Actually there had been a discussion already about this.

In principle it's a WONTFIX for Fremantle. 

The current system allows users to select the wanted marks. If the feature
needs better advertisement then let's work on that.

We do not have any data that any of the proposed solutions would be actually
beneficial, or beneficial enough to support the use of implementation and
design resources. Setting target milestone to Harmattan.
Comment 8 Lucas Maneos (reporter) 2009-10-16 12:32:18 UTC
Some more suggestions for UI hints:
- Add (or replace with) an ellipsis ("…") on the pressed dead key label.
- Blink the keyboard backlight when a dead key is pressed.
Comment 9 Andre Klapper maemo.org 2009-10-21 14:04:02 UTC
There is an internal proposal to change this, so this *might* be changed in the
Fremantle timeframe. Nothing decided yet though.

And as always: Feel free to vote for this.
Comment 10 Lucas Maneos (reporter) 2009-10-25 15:15:50 UTC
*** Bug 5778 has been marked as a duplicate of this bug. ***
Comment 11 mike bradshaw 2009-10-25 17:11:07 UTC
Also not having found TFM (and this only affecting characters on the third
row), IMHO, makes it hard to find the fix for end users 

What makes it worse is that when those characters are spread around over an
onscreen keyboard it is *really* not obvious why they don't work.
When using the physical keyboard (via CTRL+Fn) to access them, the whole row
does not work, so there is more of a hint (and the work-round of hiting a
physical key is also available).
Comment 12 Andre Klapper maemo.org 2009-10-27 14:24:49 UTC
This should be fixed once hildon-input-method-widgets version 3.3.14-1 is
released.
Closing as FIXED once this has been VERIFIED internally.
Comment 13 Andre Klapper maemo.org 2009-10-30 13:06:48 UTC
This has been fixed in package
hildon-input-method-widgets 3.3.14-1+0m5
which is part of the internal build version
2009.44-5
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

New behaviour is:
* Press once -> dead key highlighted
* Press second time -> dead key char printed
If you highlight it and then press different key it will highlight the new one
(in case it is a dead key as well) or combine the character of it (in case it
is non-dead).

I think that's an acceptable solution here and people will quickly understand
this (as I tend to try things again when they don't seem to work - same here).
Comment 14 Lucas Maneos (reporter) 2009-10-30 13:11:10 UTC
(In reply to comment #13)
> New behaviour is:
> * Press once -> dead key highlighted
> * Press second time -> dead key char printed
> If you highlight it and then press different key it will highlight the new one
> (in case it is a dead key as well) or combine the character of it (in case it
> is non-dead).

That's excellent, and much better than any of the proposed solutions IMO :-)
Comment 15 Lucas Maneos (reporter) 2009-11-01 00:04:46 UTC
*** Bug 5966 has been marked as a duplicate of this bug. ***
Comment 16 Dieter Plaetinck 2009-11-01 09:46:55 UTC
hi, so what is the reasoning behind this? why do you think a user should press
space after pressing one of the characters?

let's say I want to type 'cd ~' in the terminal.
when the '~' is ticked on the onscreen keyboard, I should go back to the
terminal to press enter.  why do i need to type a space? note that when '~' is
hilighted on the onscreen keyboard and you then type enter immediately, you're
back at your prompt saying only 'cd '.

why can't we have normal behavior for these keys?
Comment 17 Andre Klapper maemo.org 2009-11-01 13:06:48 UTC
(In reply to comment #16)
> let's say I want to type 'cd ~' in the terminal.
> why can't we have normal behavior for these keys?

Because I sometimes want to enter ñ though I have an english hardware keyboard.
Please also read the discussion here. :-)
Comment 18 Dieter Plaetinck 2009-11-01 13:18:02 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > let's say I want to type 'cd ~' in the terminal.
> > why can't we have normal behavior for these keys?
> 
> Because I sometimes want to enter ñ though I have an english hardware
> keyboard. Please also read the discussion here. :-)
> 
sorry, i didn't read closely enough.
now that I get it, I'm okay with this behavior.
Comment 19 Ryan Abel maemo.org 2009-11-07 16:36:27 UTC
*** Bug 6080 has been marked as a duplicate of this bug. ***
Comment 20 Lucas Maneos (reporter) 2009-11-23 09:36:01 UTC
*** Bug 6290 has been marked as a duplicate of this bug. ***
Comment 21 Andre Klapper maemo.org 2009-12-01 18:46:04 UTC
*** Bug 6477 has been marked as a duplicate of this bug. ***
Comment 22 Andre Klapper maemo.org 2009-12-09 21:08:49 UTC
*** Bug 6772 has been marked as a duplicate of this bug. ***
Comment 23 Lucas Maneos (reporter) 2009-12-10 03:13:52 UTC
*** Bug 6789 has been marked as a duplicate of this bug. ***
Comment 24 Andre Klapper maemo.org 2009-12-10 19:12:43 UTC
*** Bug 6818 has been marked as a duplicate of this bug. ***
Comment 25 Andre Klapper maemo.org 2009-12-11 20:03:16 UTC
*** Bug 6865 has been marked as a duplicate of this bug. ***
Comment 26 Dave Neary maemo.org 2009-12-14 13:35:13 UTC
I just voted for this bug, because I had no idea how to enter accented
characters, or how to type any of the characters in question. I will create a
wiki page for entering accented characters & special characters, since
apparently I'm not the only one (even though this is in the user manual in the
"Basic Use" chapter).
Comment 27 Andre Klapper maemo.org 2009-12-22 16:00:54 UTC
*** Bug 7210 has been marked as a duplicate of this bug. ***
Comment 28 Aniello Del Sorbo 2009-12-26 16:12:31 UTC
I can confirm this works on 2.2009.51-1.
Comment 29 Andre Klapper maemo.org 2010-01-13 00:24:54 UTC
*** Bug 7859 has been marked as a duplicate of this bug. ***
Comment 30 Andre Klapper maemo.org 2010-01-14 12:28:03 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.