Bug 5249 (int-141490)

Summary: Remove Hildon 1.x conditional code in Hildon2 version of modest
Product: [Maemo Official Applications] Email Reporter: Javier Jardón <javierjc1982>
Component: GeneralAssignee: unassigned <nobody>
Status: CLOSED FIXED QA Contact: modest-bugs
Severity: normal    
Priority: Low CC: andre_klapper, svillar
Version: 5.0/(1.2009.42-11)Keywords: patch
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   
Attachments: Remove Hildon 1.x conditional code in Hildon2 version of modest

Description Javier Jardón (reporter) 2009-09-30 20:17:08 UTC
Here a little patch to remove hildon1 conditional code not needed in hildon2
version of modest
Comment 1 Javier Jardón (reporter) 2009-09-30 20:18:25 UTC
Created an attachment (id=1390) [details]
Remove Hildon 1.x conditional code in Hildon2 version of modest

Related bug: bug #5242
Comment 2 Sergio Villar Senin 2009-11-03 18:40:21 UTC
I finally not applied your patch directly. I removed that function because it
was not used at all.

Committed in 
master 2dea0f12d724484854dd1bf75c0bad05fa151ab2

Thx for the report and the patch!
Comment 3 Andre Klapper maemo.org 2009-11-13 15:41:54 UTC
This has been fixed in package
modest 3.1.12+0m5
which is part of the internal build version
2009.46-16
(Note that 2009 is the year and the number after is the week.)

Any public update released with or after this build version will include the
fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 4 Andre Klapper maemo.org 2010-01-14 12:28:18 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.