Bug 5241 (int-141119)

Summary: Import conic support only if It's available
Product: [Maemo Official Applications] Email Reporter: Javier Jardón <javierjc1982>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: modest-bugs
Severity: normal    
Priority: Low CC: andre_klapper, svillar
Version: 5.0/(1.2009.42-11)Keywords: patch
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Linux   
Attachments: Import conic support only if It's available
Import conic support only if It's available.v2

Description Javier Jardón (reporter) 2009-09-29 14:10:09 UTC
Little patch to import conic support only if It's available
Comment 1 Javier Jardón (reporter) 2009-09-29 14:10:57 UTC
Created an attachment (id=1384) [details]
Import conic support only if It's available
Comment 2 Javier Jardón (reporter) 2009-09-29 14:16:15 UTC
This is the commit that added the import line:
https://git.maemo.org/projects/modest/?p=modest;a=commit;h=a7be4d9c27d5a6074f3a1701b12bcc2c45887022
Comment 3 Sergio Villar Senin 2009-09-30 13:13:02 UTC
Why are you changing the scope of the #ifdef ?
Comment 4 Javier Jardón (reporter) 2009-09-30 14:56:12 UTC
(In reply to comment #3)
> Why are you changing the scope of the #ifdef ?
> 

Because priv variable is not defined if you don't enter into #ifdef
MODEST_HAVE_CONIC block of code
Comment 5 Sergio Villar Senin 2009-09-30 17:35:48 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Why are you changing the scope of the #ifdef ?
> > 
> 
> Because priv variable is not defined if you don't enter into #ifdef
> MODEST_HAVE_CONIC block of code
> 

Then just move the priv definition outside the ifdef and let the ifdef'ed code
to be as small as possible
Comment 6 Javier Jardón (reporter) 2009-09-30 18:38:35 UTC
Created an attachment (id=1389) [details]
Import conic support only if It's available.v2
Comment 7 Sergio Villar Senin 2009-10-16 17:45:36 UTC
Thank you very much for the patch Javier.

Applied in Modest master 98b72bd0d65af3d98d6127e28df15362f1d33012
Comment 8 Andre Klapper maemo.org 2009-10-26 12:54:11 UTC
Fixed in internal week 43 build.
Any public update released with or after this build version (x.2009.43-y) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 9 Andre Klapper maemo.org 2010-01-14 12:28:12 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.