Bug 5033

Summary: Select/Copy text within email is nonintuitive/broken
Product: [Maemo Official Applications] Email Reporter: Tim Samoff <tim>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: modest-bugs
Severity: normal    
Priority: Low CC: andre_klapper, bugs.maemo.org, bugzilla770, bugzilla, dave.b.holden, eero.tamminen, fredrik, juke, laurent, luarvique, maemo, mail, mikko.kupila, olivier.crete, peltsip, radusebastian_capitanu, svega85, svisvanatha, tri, unaiur, zaheermerali
Version: 5.0/(3.2010.02-8)   
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: All   
Bug Depends on: 4619    
Bug Blocks:    

Description Tim Samoff (reporter) maemo.org 2009-08-31 05:21:01 UTC
SOFTWARE VERSION:
1.2009.34-10

STEPS TO REPRODUCE THE PROBLEM:
Open email.

EXPECTED OUTCOME:
Tap/drag (as well as Shift/arrows) should work in open emails, as well as
editable input fields (see below).

ACTUAL OUTCOME:
Selecting text is impossible unless an email is replied to or forwarded (i.e.,
the email text is in an editable input field). And, then, text is only
selectable via the hardware Shift/arrows.

REPRODUCIBILITY:
Always.
Comment 1 Andre Klapper maemo.org 2009-08-31 14:00:52 UTC
For the sake of consistency this should just be the same as the funky browser
mode shown in http://www.youtube.com/watch?v=RP5R-5NX1BE at 1'42".
Comment 2 zaheer merali 2009-10-13 18:44:24 UTC
agreed both with it being annoying to have to reply to a mail just to select
text to copy and with it being done similar to the pointer mode the browser
has.
Comment 3 Olivier Crête 2009-10-28 10:13:35 UTC
Seems like the internal bug says that the pannable widget does not support
selection and that this is not going to change.. We (the community) should
probably puah to get (selection mode) supporte outside of browserd based apps.
Comment 4 Olivier Crête 2009-10-28 10:38:33 UTC
actually, the underlying bug here is #4619.... which seems more promising
Comment 5 Tim Samoff (reporter) maemo.org 2009-10-28 13:36:20 UTC
Just as a note: At the Summit, Oleg Romashin (I think) mentioned that the
browser team was working on modularizing much of the functionality (including
selection mode) so that it could be used outside of the browser. But, they
wanted to make clear that the priorities would be placed on those items that
were requested most.
Comment 6 Lucas Maneos 2009-11-20 13:13:26 UTC
*** Bug 6258 has been marked as a duplicate of this bug. ***
Comment 7 bugs.maemo.org@falkensweb.com 2009-12-16 12:28:04 UTC
This is a common action users will want to perform... not just in the email
app. but more generally...
Comment 8 Tim Samoff (reporter) maemo.org 2009-12-16 15:06:15 UTC
(In reply to comment #7)
> This is a common action users will want to perform... not just in the email
> app. but more generally...
> 

Hi. If you find other apps/areas where this is needed, please post new, unique
bug reports. Thanks!
Comment 9 bugs.maemo.org@falkensweb.com 2009-12-16 18:34:50 UTC
I wasn't trying to take over this bug, have no fear. I mearly wanted to point
out that because it is used elsewhere (other platforms users will have exposure
too), it should be strong candidate for getting fixed. Even if it means digging
into the guts of the code to do.

Never mind it's a very natural thing way to interact, that many people will
try, and then be annoyed that it doesn't work.
Comment 10 Tim Samoff (reporter) maemo.org 2010-01-13 15:06:59 UTC
In response to making this bug dependent on Bug #4619 (maybe I should leave
this comment there also, but I won't)... I know it's been stated elsewhere (and
I even asked the question to some of the browser guys during Maemo Summit '09),
but why not open the swipe/cursor interaction mode in all of Fremantle? That
way every app that requires panning and selecting can use it.
Comment 11 Lucas Maneos 2010-01-15 02:41:29 UTC
*** Bug 5360 has been marked as a duplicate of this bug. ***
Comment 12 Lucas Maneos 2010-01-15 02:43:27 UTC
*** Bug 7930 has been marked as a duplicate of this bug. ***
Comment 13 Laurent GUERBY 2010-01-20 12:01:53 UTC
For example if you get someone home address in an email you have no practical
way to copy/paste it to your contacts.
Comment 14 ossipena 2010-02-10 09:32:34 UTC
I confirm this bug with fw 5.0 (2.2009.51-1).

(havent got rights to modify version myself)
Comment 15 Andre Klapper maemo.org 2010-02-10 16:52:02 UTC
The fix for bug 4619 is not yet available for public. Once it is, this one here
should be solved too.
Comment 16 Venomrush 2010-03-08 21:07:53 UTC
*** Bug 9461 has been marked as a duplicate of this bug. ***
Comment 17 Eero Tamminen nokia 2010-04-09 13:13:53 UTC
(In reply to comment #15)
> The fix for bug 4619 is not yet available for public. Once it is, this one here
> should be solved too.

Shouldn't this be set as FIXED with PR1.2 then too?
Comment 18 Andre Klapper maemo.org 2010-04-09 13:23:00 UTC
Uh true. Thanks for noticing it. :-)
Comment 19 Unai Uribarri 2010-05-27 13:38:09 UTC
This bug isn't fixed in PR1.2. I'm unable to select any text.
Comment 20 Dave Holden 2010-05-27 13:43:43 UTC
Confirmed. Not fixed in my version, 10.2010.19-1.203.1
Comment 21 Oskar 2010-05-27 14:04:47 UTC
Unai, Dave:

Did you hold down the shift key when trying? This is how it works now. I can
confirm it for my PR 1.2 installation.
Comment 22 Dave Holden 2010-05-27 14:06:53 UTC
Awesome, holding Shift works just fine.

I must have missed that in the new PR1.2 user manual. ;)
Comment 23 Unai Uribarri 2010-05-27 19:27:41 UTC
I was expecting it to behave like the browser: dragging at the botton-left
corner an icon is shown that allows to change to select mode. But it actually
works.
Comment 24 Radu Capitanu 2010-05-27 19:29:25 UTC
(In reply to comment #21)
> Unai, Dave:
> 
> Did you hold down the shift key when trying? This is how it works now. I can
> confirm it for my PR 1.2 installation. 
> 

Working in PR1.2 with shift holded!
Comment 25 Eero Tamminen nokia 2010-05-28 10:20:19 UTC
(In reply to comment #23)
> I was expecting it to behave like the browser: dragging at the botton-left
> corner an icon is shown that allows to change to select mode. But it actually
> works.

Browser is a special case for most of the things because the interaction is to
large degree dictated mostly how the www-pages themselves work (flash and
javascript programs own input handling).
Comment 26 Fredrik Idréus 2010-05-28 11:46:04 UTC
Now I can select text, it works mostly in the top of the mail.
But if I try to select some text one or two screens down, as soon as I release
shift and stylus from screen it selects several characters/lines to the
left/up.

I've confirmed it on another N900 PR1.2 here...
Comment 27 Neil MacLeod maemo.org 2010-05-28 17:55:18 UTC
(In reply to comment #26)
> Now I can select text, it works mostly in the top of the mail.
> But if I try to select some text one or two screens down, as soon as I release
> shift and stylus from screen it selects several characters/lines to the
> left/up.
> 
> I've confirmed it on another N900 PR1.2 here...
> 

Confirming - it is impossible to select text when the email has been scrolled
by more than a few lines.

Bugmail emails are a good example - scroll the email up by 2-3 lines then try
to select a line of text on the last visible line and when the finger/stylus is
lifted the selection goes haywire and a number of lines of previously
unselected text becomes selected. Selecting text at the very bottom of the
email is simply impossible, whether the stylus/finger is lifted or not.

I guess this needs to be raised as a separate bug - see bug 10390 and vote...