Bug 4918 (int-132979)

Summary: Locales not working correctly
Product: [Maemo Official Applications] Email Reporter: Javier Jardón <javierjc1982>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: modest-bugs
Severity: normal    
Priority: Medium CC: andre_klapper, svillar
Version: 5.0/(1.2009.42-11)Keywords: patch
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: x86   
OS: Linux   
Attachments: Fix locales problem
modest screenshot with not working locales
modest screenshot after appliying the patch

Description Javier Jardón (reporter) 2009-08-13 12:28:57 UTC
The locales in gnome version of modest is not working correctly.

Here a patch to fix the problem.
Comment 1 Javier Jardón (reporter) 2009-08-13 12:29:33 UTC
Created an attachment (id=1311) [details]
Fix locales problem
Comment 2 Andre Klapper maemo.org 2009-08-13 13:40:02 UTC
Can you elaborate a bit more?
e.g. why it is not working and why the patch fixes it?
Comment 3 Javier Jardón (reporter) 2009-08-13 14:39:34 UTC
Created an attachment (id=1314) [details]
modest screenshot with not working locales
Comment 4 Javier Jardón (reporter) 2009-08-13 14:43:23 UTC
Created an attachment (id=1315) [details]
modest screenshot after appliying the patch
Comment 5 Sergio Villar Senin 2009-09-30 13:32:18 UTC
Patch looks good. As far as I remember we had that code some time ago. Don't
know why we changed it...

Thx for the patch!

Applied in Modest master f3c4a95b7b607e8b43bcfdea831084d3884532f6
Comment 6 Andre Klapper maemo.org 2009-10-26 12:54:24 UTC
Fixed in internal week 43 build.
Any public update released with or after this build version (x.2009.43-y) will
include the fix.
Please verify that the new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.
Comment 7 Andre Klapper maemo.org 2010-01-14 12:28:00 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.