Bug 4908

Summary: IRC Chat ignores /Me command (capital letter)
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: Jason Carter <jay>
Component: MessagingAssignee: rtcomm <rtcomm>
Status: RESOLVED WONTFIX QA Contact: im-chat-bugs
Severity: minor    
Priority: Low CC: andre_klapper, josh
Version: 4.1.3 (5.2008.43-7)   
Target Milestone: ---   
Hardware: All   
OS: Maemo   
Bug Depends on: 5139    
Bug Blocks:    
Attachments: results

Description Jason Carter (reporter) 2009-08-12 16:12:22 UTC
SOFTWARE VERSION: 5.2008.43-7
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
1) Install RTCOMM.
2) Add an account for IRC using any server.
3) Join any IRC chatroom.
4) Type in /Me test

EXPECTED OUTCOME: IRC should report back with [nick] test written in green to
the channel.

ACTUAL OUTCOME: IRC chat sends literal /Me test so it appears the user simply
said /Me test to the channel on purpose.

REPRODUCIBILITY: Always
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED: RTCOMM

OTHER COMMENTS: /me test works perfectly fine. /Me, /mE and /ME do not get
recognized and get sent literally. See screenshot being attached momentarily.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2;
.NET CLR 3.5; ffco7) Gecko/2008090514 Firefox/3.0.2
Comment 1 Jason Carter (reporter) 2009-08-12 16:15:42 UTC
Created an attachment (id=1307) [details]
results
Comment 2 Andre Klapper maemo.org 2009-08-13 12:37:04 UTC
Yes, "/me" (small letters) should work, see bug 786.

Does stuff like "/TOpIC" or "/KIcK" work?

I wonder if there's at least some consistent implementation...
Comment 3 Josh Triplett 2009-12-10 03:54:25 UTC
I don't think it makes sense to attempt to handle commands like these
case-insensitively.  Many other clients don't.  Instead, I'd propose making it
easier to type the commands correctly: when you type a leading /, the next
letter should use lowercase by default unless explicitly shifted, even if you
have automatic capitalization turned on otherwise.
Comment 4 Jason Carter (reporter) 2009-12-10 04:10:56 UTC
(In reply to comment #3)
> I don't think it makes sense to attempt to handle commands like these
> case-insensitively.  Many other clients don't.  Instead, I'd propose making it
> easier to type the commands correctly: when you type a leading /, the next
> letter should use lowercase by default unless explicitly shifted, even if you
> have automatic capitalization turned on otherwise.
> 

Josh, that's fine when you're dealing with clients running on computers with
full keyboards but becomes a huge pain in the ass when you have text
autocapitalizing like you do on the tablets/N900.
Comment 5 Josh Triplett 2009-12-10 04:30:03 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > I don't think it makes sense to attempt to handle commands like these
> > case-insensitively.  Many other clients don't.  Instead, I'd propose making it
> > easier to type the commands correctly: when you type a leading /, the next
> > letter should use lowercase by default unless explicitly shifted, even if you
> > have automatic capitalization turned on otherwise.
> > 
> 
> Josh, that's fine when you're dealing with clients running on computers with
> full keyboards but becomes a huge pain in the ass when you have text
> autocapitalizing like you do on the tablets/N900.
> 

Hence the rest of my comment that you quoted, saying that an initial '/' should
make the next letter *not* automatically capitalized.
Comment 6 Andre Klapper maemo.org 2010-03-11 16:01:21 UTC
This is a WONTFIX for Maemo4.
If bug 5139 for Maemo5 gets solved in the future and if the problem reporterd
here will be still an issue in Maemo5 after fixing bug 5139, please update this
report (steps, Version field) and reopen it. Thanks.
Comment 7 Josh Triplett 2010-03-11 20:41:33 UTC
For anyone following this bug as I did because they care about protocols other
than IRC, also see bug 5350.