Bug 4889 (int-132520)

Summary: Use single GTK+ includes
Product: [Maemo Official Applications] Email Reporter: Javier Jardón <javierjc1982>
Component: GeneralAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: modest-bugs
Severity: normal    
Priority: Low CC: andre_klapper, svillar
Version: 5.0/(2.2009.51-1)Keywords: patch
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: Linux   
URL: http://live.gnome.org/GnomeGoals/CleanupGTKIncludes
Attachments: Use single GTK+ includes

Description Javier Jardón (reporter) 2009-08-07 19:44:51 UTC
GTK+ and other libraries now require that only their top-level header file is
included.

See http://live.gnome.org/GnomeGoals/CleanupGTKIncludes for more info
Comment 1 Javier Jardón (reporter) 2009-08-07 19:51:19 UTC
Created an attachment (id=1299) [details]
Use single GTK+ includes
Comment 2 Javier Jardón (reporter) 2009-08-07 19:54:55 UTC
The patch only modifies files needed by the Gnome version of Modest
Comment 3 Andre Klapper maemo.org 2009-08-11 23:50:04 UTC
(In reply to comment #0)
> GTK+ and other libraries now require

Well, it still compiles, so it's not yet required.
It will most probably be required by GNOME 3 though, true. :-)
Comment 4 Sergio Villar Senin 2009-09-30 13:32:15 UTC
Patch looks good.

Thank you very much!

Applied in Modest master 5f456f4b288067f9de646b31adabedef5a7171af
Comment 5 Andre Klapper maemo.org 2010-03-15 20:55:51 UTC
Setting explicit PR1.2 milestone (so it's clearer in which public release the
fix will be available to users).

Sorry for the bugmail noise (you can filter on this message).