Bug 4583 (int-119009)

Summary: hildon-fm (File System UI) documentation: No descriptions available
Product: [Maemo Official Platform] Desktop platform Reporter: Murray Cumming <murrayc>
Component: File System UIAssignee: Marius Vollmer <marius.vollmer>
Status: RESOLVED FIXED QA Contact: file-system-ui-bugs
Severity: normal    
Priority: Low CC: andre_klapper, csaavedra
Version: 5.0:(10.2010.19-1)Keywords: docs
Target Milestone: 5.0/(20.2010.36-2)   
Hardware: All   
OS: Linux   
URL: http://maemo.org/api_refs/5.0/beta/hildonfm/

Description Murray Cumming (reporter) 2009-05-25 13:23:01 UTC
The hildon-fm classes have no descriptions:
http://maemo.org/api_refs/5.0/beta/hildonfm/

For instance:
http://maemo.org/api_refs/5.0/beta/hildonfm/HildonFileChooserDialog.html#HildonFileChooserDialog.description

At the least, there should be some explanation of why these widgets exist and
should be used instead of the regular GtkFileChooserDialog and
GtkFileChooserButton.

By the way there is no hildon-fm component in bugzilla, so I guessed that
hildon-widgets might be the next best choice.
Comment 1 Andre Klapper maemo.org 2010-06-21 14:41:56 UTC
This has been fixed for the next public update.
Comment 2 Andre Klapper maemo.org 2010-10-25 17:13:32 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.