Bug 4450

Summary: libhildonfm2-dev lacks hildon-file-system-*.h header files
Product: [Maemo Official Platform] Desktop platform Reporter: Anderson Lizardo <anderson.lizardo>
Component: File System UIAssignee: Marius Vollmer <marius.vollmer>
Status: RESOLVED FIXED QA Contact: file-system-ui-bugs
Severity: normal    
Priority: Medium CC: andre_klapper, soumya.3.bijjal
Version: 5.0-beta   
Target Milestone: 5.0-beta   
Hardware: All   
OS: Linux   

Description Anderson Lizardo (reporter) 2009-05-03 03:38:38 UTC
SOFTWARE VERSION: Fremantle 5.0 beta SDK

STEPS TO REPRODUCE THE PROBLEM:

1. fakeroot apt-get install libhildonfm2-dev
2. Either compile a .c file that include <hildon/hildon-fm.h> or run the
following to trigger the missing headers:

echo '#include <hildon/hildon-fm.h>' | \
gcc -E `pkg-config --libs --cflags hildon-fm-2` - > /dev/null

EXPECTED OUTCOME:

The source file that includes <hildon/hildon-fm.h> should compile without
errors.

ACTUAL OUTCOME:

The following errors appear when compiling:

/usr/include/hildon-fm-2/hildon/hildon-fm.h:18:47: error:
hildon-file-system-dynamic-device.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:20:45: error:
hildon-file-system-local-device.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:22:37: error:
hildon-file-system-obex.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:23:46: error:
hildon-file-system-remote-device.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:24:37: error:
hildon-file-system-root.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:25:36: error:
hildon-file-system-smb.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:26:49: error:
hildon-file-system-special-location.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:28:37: error:
hildon-file-system-upnp.h: No such file or directory
/usr/include/hildon-fm-2/hildon/hildon-fm.h:29:39: error:
hildon-file-system-voldev.h: No such file or directory

REPRODUCIBILITY: always

EXTRA SOFTWARE INSTALLED: none (only maemo-sdk-dev metapackage is required)
Comment 1 Andre Klapper maemo.org 2009-05-04 14:38:45 UTC
Soumya, as this refers to the -dev package:
Is this an SDK-only bug (->reassign) or is this something worth to import?
Comment 2 Soumya nokia 2009-05-04 14:52:00 UTC
(In reply to comment #1)
> Soumya, as this refers to the -dev package:
> Is this an SDK-only bug (->reassign) or is this something worth to import?
> 

This bug is in the right component (=not an SDK only bug). 
But, it seems to be fixed in the next version of the package 1:2.11+0m5
internally. 
We will check if it breaks the current SDK configuration. If not, the updated
version will be uploaded to the repository. In either case, I will comment
here.
Comment 3 Soumya nokia 2009-05-04 16:11:17 UTC
OK.. New libhildonfm2* packages are now available in the repository. Please
update your targets to get the latest version 1:2.11+0m5.