Bug 4225

Summary: The x11vnc does not work on some areas of the screen
Product: [Maemo Official Platform] Desktop platform Reporter: Walter Guerra <walter.guerra>
Component: Application MenuAssignee: Claudio Saavedra <csaavedra>
Status: RESOLVED WONTFIX QA Contact: task-navigator-bugs
Severity: normal    
Priority: Low CC: andre_klapper, carsten.munk, eero.tamminen, jarmo.tikka, kimmo.hamalainen, maacruz, maemo, quim.gil, walter.guerra
Version: 4.1.3 (5.2008.43-7)Keywords: community-diablo, patch
Target Milestone: ---   
Hardware: ARM   
OS: Maemo   
Attachments: Patch that corrects the problem
Cleaned-up version of above
x11vnc armel package for Fremantle alpha
Cleaned-up version of above

Description Walter Guerra (reporter) 2009-03-19 23:20:36 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

In some areas of the screen the x11vnc does not work due to a use of the xInput
extension no longer used at diablo

STEPS TO REPRODUCE THE PROBLEM:

1. Run x11vnc server at maemo
2. Connect to it with any vnc client
3; Try to open the application menu 

EXPECTED OUTCOME:

The menu to open

ACTUAL OUTCOME:

Nothing happens

REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7)
Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7
Comment 1 Walter Guerra (reporter) 2009-03-19 23:22:30 UTC
Created an attachment (id=1142) [details]
Patch that corrects the problem
Comment 2 Lucas Maneos 2009-03-20 15:50:52 UTC
Created an attachment (id=1143) [details]
Cleaned-up version of above

Thanks for looking at this.  The patch itself had some problems (parts of it
were reversed, noise about files not present in the source tarball, not in
unified format - see http://wiki.maemo.org/The_Good_Patch), attaching a
cleaned-up version.
Comment 3 Lucas Maneos 2009-03-20 16:03:05 UTC
Confirming.  Home applets also do not receive x11vnc input.
Comment 4 Lucas Maneos 2009-03-20 17:01:15 UTC
The patch appears to fix the application menu (not qualified to comment on any
side-effects), but not the home applet case.   Naively commenting out the
gdk_input_set_extension_events() call in
hildon_desktop_home_item_create_icon_window() didn't make a difference.
Comment 5 Walter Guerra (reporter) 2009-03-20 17:10:22 UTC
When I commented out the gdk_input_set_extension_events at the
libhildondesktop/hildon-desktop-home-item.c file, the home applets started
working.

I tested with the clock and google applet, and both worked ok.

Are you talking about these applets?
Comment 6 Lucas Maneos 2009-03-20 17:22:52 UTC
Yes, those. It also works for me now, but only after a reboot (the application
menu started working simply by restarting hildon-desktop after installing the
new .debs).
Comment 7 Andre Klapper maemo.org 2009-03-23 14:57:52 UTC
Kimmo, can I ask you to take a look at this patch, comment it and whether it
makes sense to include for Diablo (most probably not high enough priority and
hence WONTFIX) and/or Fremantle (if the code base hasn't changed that much)?
TIA.
Comment 8 Quim Gil nokia 2009-03-23 16:36:28 UTC
anybody willing to compile X11vnc for Fremantle in order to try to reproduce
this?
Comment 9 Lucas Maneos 2009-03-23 19:47:37 UTC
AFAICT those g[dt]k_input_set_extension_events calls are related to the
stylus/finger detection that went away in Chinook.  I don't know much about
extension events in general, but I wonder whether the calls may still be useful
upstream and/or other projects (perhaps with other extensions) - ie should they
be removed or just #ifdef'ed out for maemo?
Comment 10 Lucas Maneos 2009-03-23 20:01:15 UTC
Created an attachment (id=1144) [details]
x11vnc armel package for Fremantle alpha

(In reply to comment #8)
> anybody willing to compile X11vnc for Fremantle in order to try to reproduce
> this?

Attached.  FWIW the app menu seems to work ok in scratchbox, but we don't have
home applets there yet.
Comment 11 Eero Tamminen nokia 2009-03-24 18:59:35 UTC
The patch changelog change in patch says "removed" while the input extension
stuff is actually just commented out (with C++ comments in C code).  IMHO it
would be just better to remove it completely at least in the applications menu
case as it AFAIK doesn't anymore do anything with that information.
Comment 12 Andre Klapper maemo.org 2009-03-24 19:29:33 UTC
Lucas, can you update the patch in comment 2?
I assume it applies to Diablo only, but a patch for Fremantle is of course also
highly welcome! :)
Comment 13 Lucas Maneos 2009-03-24 20:16:58 UTC
Created an attachment (id=1148) [details]
Cleaned-up version of above

(In reply to comment #12)
> Lucas, can you update the patch in comment 2?

Done, including the change in comment 4.

> I assume it applies to Diablo only, but a patch for Fremantle is of course also
> highly welcome! :)

I don't think the bug applies there - apart from comment 10, the Fremantle
hildon-desktop code looks completely different, and contains no references to
*_set_extension_events.
Comment 14 Andre Klapper maemo.org 2009-04-22 18:11:03 UTC
CC'ing Carsten as the patch might be interesting for Mer too.
Comment 15 Claudio Saavedra 2009-05-06 15:39:38 UTC
Moving to home.
Comment 16 Eero Tamminen nokia 2009-05-07 15:10:22 UTC
>> 3; Try to open the application menu 
...
> Moving to home.

Application menu is Task Navigator button.
Comment 17 Andre Klapper maemo.org 2009-05-19 18:19:29 UTC
(In reply to comment #13)
> I don't think the bug applies there - apart from comment 10, the Fremantle
> hildon-desktop code looks completely different, and contains no references to
> *_set_extension_events.

Thanks a lot for checking this in Fremantle - so it'sery unlikely to apply.
Unfortunately it's a WONTFIX for Diablo (which is in maintenance mode, and this
is not a critical issue). Carsten is already CC'ed as the patch might be
interesting for the Mer project.
Comment 18 Lucas Maneos 2009-10-22 07:57:43 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.
Comment 19 Jarmo Tikka nokia 2009-10-22 12:04:53 UTC
I am not sure is this problem is the same that we have fixed for X11vnc on
Diablo. We fixed similar problem for Diablo with updated hildon-desktop that
required some cleaning up. As there were no more Diablo maintenance releases we
released new cleaned hildon-desktop package as part of Maemo PC Connectivity
from Garage.maemo.org. See instructions how to install new updated
hildon-desktop from our Maemo PC Connectivity dcoumentation
(http://pc-connectivity.garage.maemo.org/2nd_edition/) see chapter "Installing
X11VNC on Diablo". BTW x11vnc armel pacakge that should work with updated
hildon-desktop is in Diablo extras-devel.
Comment 20 Miguel Angel 2010-08-01 14:57:56 UTC
@Jarmo: where can be found the sources or patches of your updated
hildon-desktop? I'd like to rebuild it with the lock desktop applets patch