Bug 4178 (int-107812)

Summary: hildon-input-method needs a finger keyboard example
Product: [Maemo Official Platform] Desktop platform Reporter: Carsten Munk <carsten.munk>
Component: Input method frameworkAssignee: Murray Cumming <murrayc>
Status: RESOLVED FIXED QA Contact: input-method-framework-bugs
Severity: major    
Priority: High CC: andre_klapper, eero.tamminen, femorandeira, maemo, murrayc, quim.gil, richard.sun, tero.kojo, x2rich
Version: 5.0-beta2   
Target Milestone: 5.0 (1.2009.41-10)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 3073    
Attachments: Screenshots of the two example keyboards

Description Carsten Munk (reporter) maemo.org 2009-03-03 14:21:07 UTC
Disclaimer: this is a bug related to HIM in a setting other than Maemo and I
cannot see why this happens, but upgrading from HIM 2.0.4 to Fremantle version
seems to have killed stylus keyboard plugin capability.

SOFTWARE VERSION:
5.0-alpha

STEPS TO REPRODUCE THE PROBLEM:

Try to utilize hildon-input-method-plugins-example with Fremantle HIM by
setting himExample_vkb as /apps/osso/inputmethod/input_method_plugin

EXPECTED OUTCOME:

Ability to use stylus keyboard plugin.

ACTUAL OUTCOME:

Stylus keyboard does not pop up.

REPRODUCIBILITY:
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

I cannot for the life of me see in the code where this problem happens, but
would like to ask for a gconf example where HIM works with himExample_vkb, but
if HIM is actually hard-wired and such an example cannot be produced, this is a
bug report about that, since that no OSS finger keyboard plugins exist and the
existing example stylus keyboard cannot be used.

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6)
Gecko/2009011913 Firefox/3.0.6
Comment 1 Quim Gil nokia 2009-03-04 08:14:10 UTC
The stylus keyboard has been dropped in Fremantle, see
http://maemo.org/development/sdks/maemo5_alpha_overview/

If that means that no HIM example keyboard is useful now then it is fair to ask
for an example keyboard useful for Fremantle. I guess Mohammad is the right
assignee to provide it.
Comment 2 Ryan Abel maemo.org 2009-04-22 22:29:38 UTC
(In reply to comment #1)
> The stylus keyboard has been dropped in Fremantle, see
> http://maemo.org/development/sdks/maemo5_alpha_overview/
> 

There seems to be a fair bit of interest in implementing a community stylus
keyboard, and not being able to use the input method "framework" (a framework
with one purpose aint much of a framework) to develop it certainly throws a
wrench in the works. Raising priority and severity.
Comment 3 Quim Gil nokia 2009-04-23 01:48:01 UTC
Correct me if I'm wrong but one thing is the lack of a convenient example and
another thing is 'not being able to use the input method "framework"'.

Has anybody tried to fit the Diablo stylus keyboard that was provided as
example in the Fremantle Hildon Input Method fw?

Anyway, Tero knows better when the finger keyboard example is supposed to be
done.
Comment 4 Ryan Abel maemo.org 2009-04-23 02:06:37 UTC
(In reply to comment #3)
> Has anybody tried to fit the Diablo stylus keyboard that was provided as
> example in the Fremantle Hildon Input Method fw?
> 

Yes, that should the the scenario that was outlined in the report.
Comment 5 Tero Kojo nokia 2009-04-23 08:46:24 UTC
(In reply to comment #3)
> Anyway, Tero knows better when the finger keyboard example is supposed to be
> done.
> 

The keyboard is in the works and there should be code to show in a week or two.
Comment 6 Andre Klapper maemo.org 2009-07-01 13:26:06 UTC
(In reply to comment #5)
> The keyboard is in the works and there should be code to show in a week or two.

Tero, is there some progress here?
Comment 7 Tero Kojo nokia 2009-07-01 13:53:45 UTC
Being worked on by Murray. Wasn't as simple as expected.
Reassigning to Murray.
Comment 8 Felipe Erias Morandeira 2009-07-21 17:01:12 UTC
In previous versions of the platform, the HIM had a little window that
sat at the bottom of the screen and that was the place where most
plugins (including the example plugin) were located. This window does
not exist in Fremantle, and that is the basic reason why the example needs to
be modified.

The GConf settings for selecting the plugin to be used on each trigger are
located under "/apps/osso/inputmethod/default-plugins/".
Comment 9 Murray Cumming 2009-07-24 17:43:53 UTC
I wonder, does anybody else using the public SDK have any gconf values under
/apps/osso/inputmethod/default-plugins/".

You can see with 
gconftool-2 --dump /apps/osso/inputmethod/default-plugins
Comment 10 Lucas Maneos 2009-07-24 21:19:55 UTC
(In reply to comment #9)
> I wonder, does anybody else using the public SDK have any gconf values under
> /apps/osso/inputmethod/default-plugins/".

Nope, completely empty here.
Comment 11 Richard Sun (Nokia) 2009-07-27 16:43:29 UTC
how about try to build latest HIM package from stage?
Comment 12 Murray Cumming 2009-07-28 15:16:52 UTC
(In reply to comment #11)
> how about try to build latest HIM package from stage? 

As mentioned in 
https://bugs.maemo.org/show_bug.cgi?id=4729
the current svn of hildon-input-manager can't be built in the beta2 SDK,
without installing a GTK+ from svn, so this can't be reliably confirmed.
Comment 13 Murray Cumming 2009-09-09 11:30:44 UTC
I have not made much progress - I still can't get the finger keyboard example
to ever show up on screen, for instance in maemopad.

However, after lots of email back and forth I have maybe discovered the new
gconf settings that should be used to specify the use of the finger keyboard. I
have noted these in the README:
https://stage.maemo.org/viewcvs.cgi/projects/haf/trunk/hildon-input-method-plugins-example/README?root=maemo&view=markup
(I have also updated that svn to build in the Beta2 SDK, now that I have write
access.

The new "tips" project might also provide a UI to set the correct gconf keys,
but I can't get it to work in the betaSDK. It seems to be an extension for the
Text Input settings/control-panel (osso-applet-textinput?), which is not
available in the Beta2SDK. I have asked the author via email to actually write
something in its README. Although it seemed to work in the internal SDK, it did
not magically make the example work.

The extreme lack of API documentation is an obstacle, and I'm not getting much
help, so it's taken me a long time to get even this far. I don't have much
confidence now that I can ever get this to work, but I'll try to dig into the
source code of the various closed-source modules to discover what the code
should really do now.
Comment 14 Murray Cumming 2009-09-09 11:35:07 UTC
(In reply to comment #13)
> The new "tips" project might also provide a UI to set the correct gconf keys

I forgot to mention the URL:
https://garage.maemo.org/scm/?group_id=1011
(It has code in svn.)
Comment 15 Felipe Erias Morandeira 2009-09-10 19:59:26 UTC
There are a couple of example virtual keyboards for Fremantle in the
hildon-input-method-plugins-example trunk that have been created recently by
Joaquim Rocha and me.

The old him-vkb-example will not work unchanged in Fremantle since, as I said
before, the UI has changed and the Hildon Input Method doesn't have a small
window at the bottom of the screen where it holds its plugins.

The SVN repository with the new examples:

https://stage.maemo.org/svn/maemo/projects/haf/trunk/hildon-input-method-plugins-example/

The "Text Input Plugin Selector" is a small plugin for the "Text Input" applet
in the Control Panel that will let you select the desired plugin for a given
trigger (finger, stylus or keyboard). I plan to make a initial release soon, as
so far the SVN version seems to work well.

Main page:

https://garage.maemo.org/projects/tips/

SVN repository:

https://garage.maemo.org/svn/tips
Comment 16 Murray Cumming 2009-09-10 20:07:04 UTC
Yes, finally we have good news. Joaquim Rocha and Felipe Erias Morandeira have
fixed the current example plugin and even added one more in the existing svn
module:
https://stage.maemo.org/viewcvs.cgi/projects/haf/trunk/hildon-input-method-plugins-example/README?root=maemo&view=markup

( svn co
https://stage.maemo.org/svn/maemo/projects/haf/trunk/hildon-input-method-plugins-example
)

And they work, using the gconf settings mentioned in the README! Well, testing
with maemo with the beta2 SDK, the text doesn't actually arrive in the
HildonTextView widget, but it does work with my secret internal SDK target. So
I'll just leave this open until we can confirm it with the next public SDK
release.

Thanks Felipe and Joaquim.
Comment 17 Felipe Erias Morandeira 2009-09-10 20:08:02 UTC
Created an attachment (id=1356) [details]
Screenshots of the two example keyboards

This is a screenshot showing the two keyboards in action :-)
Comment 18 Murray Cumming 2009-09-10 20:16:57 UTC
By the way, felipe, we (Openismus) added a multipress IM to regular GTK+ a
while ago:
http://git.gnome.org/cgit/gtk+/tree/modules/input/gtkimcontextmultipress.h

You might want to reuse that somehow, though that's really not important.
Comment 19 Andre Klapper maemo.org 2009-09-16 17:42:13 UTC
So can this be closed as FIXED now, or what else is needed here?
Comment 20 Carsten Munk (reporter) maemo.org 2009-09-16 17:43:19 UTC
Besides the new HIM libraries/framework versions being published in a SDK,
nothing as far as I can see.
Comment 21 Murray Cumming 2009-09-17 08:28:36 UTC
Well, like I said in comment #16, I at least need to remember to confirm it
when the next SDK is published, in case the example code gets out of sync with
the API again.
Comment 22 Murray Cumming 2009-10-14 11:11:24 UTC
I've heard from the Mer developers that these examples now work in a public SDK
(Maemo 5.0 Final). Fixed.