Bug 3934

Summary: Image zooming no longer works with images larger than the browser window
Product: [Maemo Official Applications] Browser Reporter: Ryan Abel <rabelg5>
Component: ZoomingAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: browser-zooming-bugs
Severity: enhancement    
Priority: High CC: andre_klapper, quim.gil
Version: 4.1.3 (5.2008.43-7)   
Target Milestone: 5.0 (1.2009.41-10)   
Hardware: All   
OS: Maemo   
URL: http://www.nasa.gov/images/content/297525main_ED08-0306-131_full.jpg

Description Ryan Abel (reporter) maemo.org 2008-12-18 15:45:43 UTC
SOFTWARE VERSION:
5.2008.43-7

STEPS TO REPRODUCE THE PROBLEM:

1. Load an image larger than the screen resolution in MicroB.
2. Try to tap on the image to zoom.

EXPECTED OUTCOME:
Tapping on the image causes it to zoom to fit the browser window.

ACTUAL OUTCOME:
Tapping on the image has no effect, image remains full size.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
This seems to be a regression, as I recall it working in at least Chinook and
maybe some of the earlier Diablo releases.

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us)
AppleWebKit/523.15.1 (KHTML, like Gecko) Version/3.0.4 Safari/523.15
Comment 1 Andre Klapper maemo.org 2008-12-22 14:22:40 UTC
Grepped through the Diablo Browser Specification and it's not mentioned
anywhere, so it looks like an enhancement that was not "planned" to be
supported, even if it's a regression. :-/
Comment 2 Ryan Abel (reporter) maemo.org 2008-12-29 15:37:13 UTC
(In reply to comment #1)
> Grepped through the Diablo Browser Specification and it's not mentioned
> anywhere, so it looks like an enhancement that was not "planned" to be
> supported, even if it's a regression. :-/
> 

Well, if it's NOT something planned, then the little minus magnifying glass
pointer that shows up when you hover over an image needs to be removed.
Comment 3 Quim Gil nokia 2008-12-29 18:06:11 UTC
Setting HIGH visibility.

I'm also unsure whether this is a bug or an enhancement. Maybe timeless will
tell us.
Comment 4 timeless 2008-12-29 22:27:07 UTC
i was hoping to duck this one. i checked an old diablo build (circa 4.1).
afaict this hasn't worked since diablo shipped.

iirc the feature itself was indeed not contracted and was implemented by/in
gecko (i.e. not the ui).

given that no one in the browser team is working on diablo, and given that this
seems like it's been broken for a while. i can't imagine this being fixed for a
maintenance release (if there is one, and i know nothing about such things).

i'm sorry about the feature's loss, and if someone finds the fix, i'll try to
find someone to integrate it (however, i don't know anything about integration
or release cycles, so i can't make any promises)
Comment 5 Quim Gil nokia 2009-05-18 23:45:52 UTC
Anyway, FIXED in Fremantle. I just tested with the picture linked in the bug
report. It downloads the picture directly with a size to fit in the screen.
Comment 6 Andre Klapper maemo.org 2009-09-07 14:02:07 UTC
Moving Zoom related reports to its own (new) Browser subcomponent.
Sorry for the bugmail noise.