Bug 3890 (int-123294)

Summary: Missing libhildonmime API documentation
Product: [Maemo Official Platform] Desktop platform Reporter: Miroslav Rajcic <rajcic>
Component: generalAssignee: Jarmo Tikka <jarmo.tikka>
Status: RESOLVED FIXED QA Contact: HAF QA mailing list <desktop-platform-general-bugs>
Severity: normal    
Priority: Low CC: andre_klapper, eero.tamminen, jarmo.tikka, thomas
Version: 5.0/(3.2010.02-8)Keywords: docs
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: All   
OS: All   

Description Miroslav Rajcic (reporter) 2008-11-25 13:21:25 UTC
SOFTWARE VERSION:
(Control Panel > General > About product)

STEPS TO REPRODUCE THE PROBLEM:
Missing documentation on D-BUS API supported by default applications.
I need to replace GnomeVFS code to handle opening file links on Nokia,
using D-BUS API to open a file in some of the default maemo applications.

Problem is that there is no documentation on this.
Additionally MIME system on Nokia is not documented too.

EXPECTED OUTCOME:

ACTUAL OUTCOME:

REPRODUCIBILITY:
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.4)
Gecko/2008102920 Firefox/3.0.4
Comment 1 Jarmo Tikka nokia 2008-11-25 14:18:02 UTC
MIME type handling has been documented in Diablo Reference Manual
http://maemo.org/maemo_release_documentation/maemo4.1.x/ chapters
5.4.3 Application Activation
6.10 MIME Types Mapping
and GnomeFS here in chapter 
7.2 File System - GnomeVFS
and D-Dus usage on maemo in chapter
7.3 Message Bus System - D-Bus

Are these enough for you?
Comment 2 Miroslav Rajcic (reporter) 2008-11-25 15:29:38 UTC
Unfortunately, libhildonmime library that seems to be answer to my problems is
not documented.

One of your colleagues suggested to open this bug (see
https://bugs.maemo.org/show_bug.cgi?id=3873)
Comment 3 Jarmo Tikka nokia 2008-11-26 11:28:31 UTC
Changed status to New and target milestone to Fremantle as we do not enhance
official Diablo documentation anymore with new topics. Also dependency to bug
#3873 added.
Comment 4 Eero Tamminen nokia 2008-11-26 13:19:38 UTC
(In reply to comment #3)
> Changed status to New and target milestone to Fremantle as we do not enhance
> official Diablo documentation anymore with new topics. Also dependency to bug
> #3873 added.

Documenting libhildonmime doesn't require changing GnomeVFS, they're unrelated
libraries.
Comment 5 tz 2008-12-03 19:06:39 UTC
I have a similar problem with wireless - there is some kind of interface to do
a search (similar to the command "iwlist scan"), but there is one non-working
python example which doesn't really document wlanconfd or whatever that
component is.

I can use wireless-tools so haven't looked much beyond the Python program which
may have a fix since it is a bug in a python library (yes, I shouldn't use
wireless-tools but if you don't document any other way other than direct kernel
calls, what am I supposed to use?).

The D-BUS API for a lot of applications (or system responders, or whatever) is
often nonexistent or at best light.

I don't think I filed a bug specifically on this, but I don't know which APIs
are proprietary and WONT be documented, and which ones are designed for me to
ultimately use and just haven't been.  But usually there is a closed program on
one side or the other so even the source isn't helpful.

This more general bug applies, but I'd add that even documenting the fact that
the actual API is proprietary would help.
Comment 6 Andre Klapper maemo.org 2009-01-12 13:54:42 UTC
I don't see any dependency here either - removing it.
Comment 7 Andre Klapper maemo.org 2009-06-10 19:24:49 UTC
Mass-moving package specific complaints about API documentation to the
corresponding packages plus adding "docs" keyword.
Doing this as API documentation is maintained by the developers and hence bug
reports are not visible enough if they are filed under "Development platform >
Documentation").
You can filter your bugmail by searching for "docs-cleanup-20090610".
Sorry for the noise.
Comment 8 Andre Klapper maemo.org 2009-06-17 14:09:01 UTC
STEPS TO REPRODUCE:
1. Go to http://maemo.org/api_refs/5.0/beta/

EXPECTED OUTCOME:
Find "libhildonmime" documentation

ACTUAL OUTCOME:
Do not find "libhildonmime" documentation

OTHER COMMENTS:
For *Diablo* a little bit of MIME type handling was documented in the Reference
Manual. However this request is about the *API documentation* for *Fremantle*.
Comment 9 Jarmo Tikka nokia 2009-12-28 14:02:30 UTC
Just changing target milestone to Fremantle 5.0+ as we do not yet have
Fremantel Developer Guide done.
Comment 10 Andre Klapper maemo.org 2010-02-22 19:04:40 UTC
Fixed internally, now "just" needs to be pushed online.
Comment 11 Andre Klapper maemo.org 2010-03-12 16:13:15 UTC
This has been fixed *internally*.

When the next public Maemo5 SDK update is released (for PR1.2), these API docs
will also be pushed to http://maemo.org/api_refs/5.0/beta/ .

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
http://maemo.org/community/brainstorm/view/undelayed_bugfix_releases_for_nokia_open_source_packages-002/
Comment 12 Andre Klapper maemo.org 2010-04-06 23:17:19 UTC
Hmm, still not available at http://maemo.org/api_refs/5.0/5.0-final/ though
PR1.2 **SDK** has been pushed.