Bug 3866

Summary: Please, add "last used special characters" palette
Product: [Maemo Official Platform] UI Specification Reporter: luarvique
Component: GeneralAssignee: Mohammad Anwari <mdamt>
Status: RESOLVED FIXED QA Contact: input-method-framework-bugs
Severity: enhancement    
Priority: Unspecified CC: andre_klapper, eero.tamminen, luarvique, quim.gil, roope.rainisto
Version: unspecified   
Target Milestone: Harmattan   
Hardware: N810   
OS: Maemo   

Description luarvique (reporter) 2008-11-17 18:05:47 UTC
SOFTWARE VERSION:
All

STEPS TO REPRODUCE THE PROBLEM:
1. Open virtual keyboard.
2. Click on the Characters button to show characters selection palette.

EXPECTED OUTCOME:
There should be a list of 6-10 characters that have been used last, sorted in
order of usage recency.

ACTUAL OUTCOME:
Recently used characters are not shown and have to be searched for again and
again.

REPRODUCIBILITY:
always.
Comment 1 Andre Klapper maemo.org 2008-11-18 00:42:32 UTC
luarvique: Again: Please set hardware info and the version.
"All" is inappropriate.
Comment 2 luarvique (reporter) 2008-11-18 07:36:44 UTC
(In reply to comment #1)
> luarvique: Again: Please set hardware info and the version.
> "All" is inappropriate.
In this particular case, "All" is appropriate as the problem can be recreated
in all versions of Maemo, in the same way.
Comment 3 Andre Klapper maemo.org 2008-11-18 14:16:04 UTC
Please stop ignoring my questions. You still don't tell your hardware.

(In reply to comment #2)
> In this particular case, "All" is appropriate as the problem can be recreated
> in all versions of Maemo, in the same way.

I don't care - It's only interesting for me if it happens in the latest
version. If you don't run the latest version I will ask you to test first.
Reason: There won't be another update for 3.2, 4.0, 4.1 or 4.1.1. There will be
only an update available for 4.1.2 and it will be called 4.1.3.
Comment 4 luarvique (reporter) 2008-11-18 14:26:40 UTC
SOFTWARE VERSION:
OS2008 4.2008.36-5
Comment 5 Andre Klapper maemo.org 2008-11-18 14:38:58 UTC
Thanks
Comment 6 Roope Rainisto nokia 2008-11-24 20:53:31 UTC
Moving to UI specifications.
Comment 7 Roope Rainisto nokia 2008-11-26 10:13:46 UTC
Yes, current Harmattan UI plans have included this feature.
Comment 8 luarvique (reporter) 2008-11-26 10:57:27 UTC
(In reply to comment #7)
> Yes, current Harmattan UI plans have included this feature. 
Any hope we will see it in a Diablo update? Harmattan is a way off in the
future, while the problem exists in the present.
Comment 9 Quim Gil nokia 2008-11-26 12:22:01 UTC
Harmattan is Harmattan. If we would release it as a Diablo update then it would
be a Diablo feature.

There are many problems or potential enhancements that are exist today, but
since it's not possible to deliver all of them now we have to set priorities.
Comment 10 Quim Gil nokia 2008-11-26 13:34:50 UTC
Roadmapped for Harmattan. Resolving as fixed since we have agreed that no
actual code is needed to resolve feature requests. Trust the Maemo SW product
managers.  ;)