Bug 3841

Summary: Try connect to all available connections if no previously saved ones exist
Product: [Maemo Official Platform] Connectivity Reporter: Russ Nelson <nelson>
Component: WiFiAssignee: unassigned <nobody>
Status: RESOLVED WONTFIX QA Contact: wifi-bugs
Severity: enhancement    
Priority: High CC: andre_klapper, bugzilla770, maemo, quim.gil
Version: 4.1.2 (4.2008.36-5)   
Target Milestone: ---   
Hardware: All   
OS: Linux   

Description Russ Nelson (reporter) 2008-11-01 01:02:46 UTC
STEPS TO REPRODUCE THE PROBLEM:
Try to go online in a location where you have no saved connections.

EXPECTED OUTCOME:
Connection manager should try all open access points:
<ol>
<li>Associate.  If that works,
<li>DHCP to get an address.  If that works,
<li>ping the default router.  If that works,
<li>do a DNS call to look up nokia.com.  If that works, stop searching.
</ol>


ACTUAL OUTCOME:
You're presented with a list of access points and the only way to get online is
to try them all just like a computer program would, checking each one in turn
to see if it gets you online, or if it traps you at a login screen.

REPRODUCIBILITY:
(always/sometimes/once)
always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8)
Gecko/20051202 Fedora/1.5-0.fc4 Firefox/1.5
Comment 1 Andre Klapper maemo.org 2008-11-01 23:56:53 UTC
Normally people connect to Networks they know about instead of wardriving. ;-)
-> Enhancement.
Comment 2 Russ Nelson (reporter) 2008-11-02 01:39:33 UTC
Please don't fix bugs that I report.
Comment 3 Andre Klapper maemo.org 2008-11-02 02:04:13 UTC
Sorry, that's a bit ridiculous.
It's still up to devs to decide what to fix or not, and this is a totally valid
request. Reopening.
Comment 4 Quim Gil nokia 2008-12-22 17:41:48 UTC
Name, security level and signal strength are variables that help you figuring
out what is the next connection you want to try.

How often do you find yourself in a situation where there are multiple open
networks and there is a chance of finding one 100% free?

Your proposal is interesting but raises some questions:

- A connection requiring login but no payment would be refused, but perhaps the
user would be interested about that one.

- A connection 100% free might have a signal strength or bandwith unbearable,
yet following your proposal would get the priority.

I might be wrong (this is not my domain) but it looks like it is simple just to
let the user find out the most appropriate connection based on the current
information. In my own experience either there is a single possibility to
connect for free and is clear, either no real chance to connect for free,
either the connections available are too poor to be used anyway. No matter
what, it doesn't take me more than 1-2 minutes to realize.
Comment 5 Neil MacLeod maemo.org 2008-12-22 18:04:20 UTC
Nokia created and distributed an application that already did this kind of
thing - it was called ParkWiFi[1]. I'm not entirely sure if it would facilitate
"wardriving" but it had a smarter WiFi scan function than that built into the
OS and would automatically connect to available networks. Maybe it could/should
be open sourced as I doubt it's compatible with Diablo.

1. http://www.nseries.com/770experience_2/wifi.htm
Comment 6 Quim Gil nokia 2008-12-31 03:16:11 UTC
I couldn't find any reference to that app in the link.
Comment 7 Andre Klapper maemo.org 2008-12-31 03:23:15 UTC
(In reply to comment #6)
> I couldn't find any reference to that app in the link.
> 

At least two webpages link to http://www.parkwifi.nokia.com/1,21,,,202.html
which does not exist anymore:
http://www.e-series.org/archives/104
http://net9.blogspot.com/2006/09/parkwifi-software-from-nokia.html
Comment 8 Quim Gil nokia 2008-12-31 12:45:44 UTC
Setting HIGH visibility.

All this happened before I joined. I need to ask, after the holidays.

http://web.archive.org/web/20071014003814/http://parkwifi.nokia.com/

http://web.archive.org/web/20071014014944/parkwifi.nokia.com/1,21,,,202.html

Says:

---------------

ParkWiFi Detector
This handy application will automatically detect a free Nokia ParkWiFi network
in the range and get you connected in quickly.

(...)

ParkCast
With ParkCast you can listen to radio over the WiFi on your mobile.

If you have the Nokia 770 Internet tablet you can download ParkWiFi Detector
and ParkCast applications to get connected and listen to radio.

-----------
Comment 9 Lucas Maneos 2009-01-26 15:02:00 UTC
If this is implemented please make it user-configurable and set to off by
default.  Connecting and using random access points (even if open) may be
illegal in certain jurisdictions and should not be done without the user's
explicit instruction.

Parkwifi is quite different in that it detects specific Nokia-provided access
points that the user is authorised to use.
Comment 10 Quim Gil nokia 2009-01-26 22:34:03 UTC
Comment #4 and comment #9 + the current lack of internal plans to do anything
like this look like arguments good enough to resolve this as WONTFIX.