Bug 3709

Summary: Problem: bluetooth keyboard fails to work with N800 running OS2008 (Diablo). Works under OS2007.
Product: [Maemo Official Platform] Connectivity Reporter: David Mann <juice>
Component: BluetoothAssignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: bluetooth-bugs
Severity: major    
Priority: Medium    
Version: 4.1.1 (4.2008.30-2)   
Target Milestone: ---   
Hardware: ARM   
OS: Maemo   

Description David Mann (reporter) 2008-09-14 14:11:41 UTC
SOFTWARE VERSION:
OS2007: RX-34_2007SE_4.2007.38-2_PR_COMBINED_MR0_ARM
OS2008: RX-34_DIABLO_4.2008.23-14_PR_COMBINED_MR0_ARM (plus online patch to
4.2008.30-2)

STEPS TO REPRODUCE THE PROBLEM:
Attempt to pair bluetooth HID keyboard with N800 running Diablo, from either
Control Panel -> Bluetooth Keyboard or Control Panel -> Bluetooth

EXPECTED OUTCOME:
Keyboard should be paired and can then be used to enter data

ACTUAL OUTCOME:
Keyboard cannot be paired

REPRODUCIBILITY:
Always

EXTRA SOFTWARE INSTALLED:
None

OTHER COMMENTS:
Keyboard is a KeySonic 340BT and is fully HID compliant.  Keyboard has been
proven to work with OS2007 on same N800 (i.e. issue is around Diablo bluetooth
management, not the hardware).  Keyboard also works correctly with other
hardware (e.g. Windows XP Home (laptop), Windows XP Pro (desktop), Windows
Mobile (Toshiba G900 phone)).

In N800 OS 2007, keyboard is correctly detected and paired.  Data can be
entered on the keyboard and connection can be dropped and reconnected without
issue.

In N800 OS 2008, keyboard is detected, but all pairing attempts fail.  Failure
occurs due to one of two reasons:
1) N800 quickly returns "Pairing failed.  Try Again?"
2) N800 slowly returns "Pairing failed.  Device resources exceeded" - this
appears regardless of whether correct PIN is entered on keyboard or not - i.e.
failure appears to be prior to N800 making pairing request to keyboard.

Other bluetooth devices (e.g. mobile phone) can be successfully paired with
N800 when running both OS2008 and OS2007

Attempts to work around pairing issues have failed.  The N800 backup system
does not appear to backup bluetooth settings.  Manually tarring up
/var/lib/bluetooth under OS2007 and extracting under OS2008 means that the
keyboard is listed as paired, but the N800 then refuses to connect to it (via
Bluetooth Settings -> Devices -> Edit Device -> Connect): the N800 consistently
returns the error message:
    "Connection failed to BTKB-763B"

OS2008 does not appear to have hcidump installed by default, and bluez-utils
appears to be the latest available version.  Attempts to manually download and
install bluez-hcidump.deb from maemo.org have failed: N800 reports that the arm
package is incompatible.
Comment 1 Ryan Abel maemo.org 2008-09-14 16:02:47 UTC
Please remember to search before filing new bugs.

*** This bug has been marked as a duplicate of bug 2640 ***
Comment 2 David Mann (reporter) 2008-09-14 18:27:03 UTC
(In reply to comment #1)
> Please remember to search before filing new bugs.
> 
> *** This bug has been marked as a duplicate of bug 2640 ***
> 
Ryan,

Thanks for that - I did try searching bugzilla for "bluetooth", but somehow
missed 2640!  

Looking through the comments, 2640 seems to be mostly around problems with
restoring bluetooth settings after an upgrade: my issue occurs consistently on
a new install of Diablo without any backup/restore activity.

However, comments in 2640 indicate other people have experienced the same
"no-backup" problem, and there are a number of potential suggestions which I'll
work through, to see if any are able to resolve the issue.