Bug 3279

Summary: Streamlining user access to the Extras repository
Product: [Maemo Official Applications] Settings and Maintenance Reporter: Ryan Abel <rabelg5>
Component: Application managerAssignee: Quim Gil <quim.gil>
Status: VERIFIED FIXED QA Contact: application-manager-bugs
Severity: enhancement    
Priority: Medium CC: andrew, andre_klapper, quim.gil
Version: 5.0/(1.2009.41-10)   
Target Milestone: 5.0/(2.2009.51-1)   
Hardware: All   
OS: Maemo   

Description Ryan Abel (reporter) maemo.org 2008-06-22 23:45:57 UTC
Currently, Nokia ships new tablets with the Extras repository configured, but
disabled. Although this practice may indemnify Nokia against liability based on
the quality of the packages in Extras, it also negatively impacts the tablet
user experience, by greatly increasing the difficulty of access to the
third-party applications which are such a crucial part of that experience.

The most straightforward solution to this issue (from a technical perspective,
anyway) is to simply ship the tablets with the Extras repository enabled and
call it a day. Unfortunately, this is probably not acceptable to Nokia legal,
so we have a few other possible approaches to the issue which may be more
acceptable.

A very visible and effective option (thanks to sjgadsby for this one), is to
add another step to the initial setup wizard that summarizes the benefits of
enabling Extras, offers to enable Extras for the user, and carries a health
warning and disclaimer clearing Nokia of all liability (much like the existing
disclaiming in Application manager that is show when installing software) for
the quality of the packages in Extras. Thus, new users are introduced to Extras
without the need to go digging for it on their own, and Nokia legal should be
happy with their liability standing.

A similar option to the setup-wizard one, is to add a small segment onto the
Home Tutorial Flash movie that summarizes the benefits of Extras and shows the
user how to go about enabling it. This is markedly less visible (be interesting
to know what percentage of users watch the Tutorial movie) than the
setup-wizard option, but may be worth implementing additionally or as an
alternative to it.

On a slightly different approach, the new buttons for the main view of
Application manager covered here
(http://wiki.maemo.org/User:GeneralAntilles/Improving_the_Application_manager#Main_view)
is another possible approach to introducing new users to Extras.

Any way you look at it (and especially with the improving quality of Extras
moving forward thanks to the hard work of X-Fade and others), Extras is an
important part of the tablet experience and needs to be visible to the new
user, not hidden away behind several menus and dialogs.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US)
AppleWebKit/525.18 (KHTML, like Gecko, Safari/525.20) OmniWeb/v622.1.0.101362
Comment 1 Andre Klapper maemo.org 2008-06-23 12:25:36 UTC
(In reply to comment #0)
> The most straightforward solution to this issue (from a technical perspective,
> anyway) is to simply ship the tablets with the Extras repository enabled and
> call it a day. Unfortunately, this is probably not acceptable to Nokia legal,

Maybe Quim can comment on this so we know what's possible and what's not?
Comment 2 Quim Gil nokia 2008-06-23 13:15:51 UTC
Note that mthe cause here is Nokia promoting a lot or a little the extras
repository. The Application Manager implementation just reflects the
implementation of that. To me this sounds more a 2010 objective than a specific
enhancement request for the A.M.

As a principle, it is clear that Nokia wants to promote additional software to
its customers. If it's free of charge, community based, open source... al the
better - it just fits with the kind of products the Maemo platform should be
excel at. 

However, Nokia doesn't want to take any risk, not only in terms of legal
liabilities, also in terms of bad user experience through i.e. problematic
installs, crashes, damages in system performance, bad interfaces, incomplete
features...

If the community can get a decent quality filter in extras and produce a bunch
of amazing applications as good as or better than the ones proviced by Nokia
and commercial partners, then the community repository will be promoted very
visibly. It's not a passive requirement: Nokia is willing to help achieving
that. Now the help goes through the device programs and funding and pushing
some of the work on the extras and /downloads improvements. In the future Nokia
can help on more things i.e. helping out selected projects to get that 15%
remaining to achieve mass market quality.

It's a good time to talk about this. No big changes will be seen for Diablo
beyond the extras-devel/extras setting, since this was the main objective for
this release. New things can be planned and executed pointing to Fremantle and
Harmattan.
Comment 3 Quim Gil nokia 2009-05-21 14:46:07 UTC
The current situation is: 

If the Maemo community is able to put a decent QA process in place for Extras,
then Nokia will trust it and enable this reository by default. This is the
desired scenario for everybody, but requires work (and Nokia is willing to help
e.g. funding the work needed).

If the Maemo 5 Extras repository is proven to contain software problematic for
pure end users and has not a reliable QA process then the default way for users
to get that repository installed will be to install one app from that repo
(advertized in maemo.nokia.com, maemo.org or wherever else) and then activate
the repository.

So let's work on this QA process since it's what all of us want to have in
place.
Comment 4 Ryan Abel (reporter) maemo.org 2009-10-12 22:51:41 UTC
(In reply to comment #3)
> If the Maemo community is able to put a decent QA process in place for Extras,
> then Nokia will trust it and enable this reository by default. This is the
> desired scenario for everybody, but requires work (and Nokia is willing to help
> e.g. funding the work needed).
> 

Any chance of a status update here? Currently still disabled in 41-10.
Comment 5 Andre Klapper maemo.org 2009-10-12 22:58:51 UTC
This will not happen for the final Fremantle version, but can be considered for
an SSU update as far as I remember the discussion about this.
Comment 6 Quim Gil nokia 2009-10-13 07:55:03 UTC
Basically Extras needs to proof that the QA works and there is relevant content
for end users.

The work done so far is very good! We are looking forward to get more stable
software there now that 300 users with N900 and without NDA have been
encouraged to test and give feedback.

I can't give details about releases but I believe that pushing Extras hard
these days will help having it _basically_ enabled by the time the first wave
of N900 users get their devices.
Comment 7 Ryan Abel (reporter) maemo.org 2009-10-13 08:15:08 UTC
(In reply to comment #6)
> Basically Extras needs to proof that the QA works and there is relevant content
> for end users.
> 

Can we get some Nokia input on this, then?

> I can't give details about releases but I believe that pushing Extras hard
> these days will help having it _basically_ enabled by the time the first wave
> of N900 users get their devices.
> 

What does "basically" mean? It's either enabled or it isn't. . . .
Comment 8 Andrew Flegg maemo.org 2009-10-23 19:31:45 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Basically Extras needs to proof that the QA works and there is relevant 
> > content for end users.
> 
> Can we get some Nokia input on this, then?

And what factors we need to meet to show it "working"?

> > I can't give details about releases but I believe that pushing Extras hard
> > these days will help having it _basically_ enabled by the time the first wave
> > of N900 users get their devices.
> > 
> 
> What does "basically" mean? It's either enabled or it isn't. . . .

Latest comment from Quim suggest it *isn't*:

http://talk.maemo.org/showpost.php?p=356591&postcount=58
Comment 9 Quim Gil nokia 2009-10-26 09:54:17 UTC
More explanations at http://talk.maemo.org/showpost.php?p=356691&postcount=72

Extras is doing the right thing already and only needs to continue adding good
quality software.
Comment 10 Quim Gil nokia 2009-11-11 14:03:52 UTC
The "maemo.org Applications" repository will be enabled by default in the first
maintenance release.

This is a way to say Congratulations for the great work done with the
Extras-testing QA process and the 50 applications available at
http://maemo.org/downloads/Maemo5/ by the N900 sales start.
Comment 11 Quim Gil nokia 2009-12-23 18:41:33 UTC
FIXED in Fremantle PR1.1.
Comment 12 Andre Klapper maemo.org 2010-01-14 12:26:41 UTC
The problem reported here should be fixed in the update released today for
public: The Maemo5 update version 2.2009.51-1 (also called "PR1.1" sometimes).
Please leave a comment if the problem is not fixed for you in this update
version.