Bug 3236

Summary: User login page for the wiki needs to mention that login information is from Garage and provide a link to the Garage registration page
Product: [Websites] maemo.org Website Reporter: Ryan Abel <rabelg5>
Component: WikiAssignee: Ferenc Szekely <ferenc>
Status: VERIFIED FIXED QA Contact: midgard <midgard>
Severity: minor    
Priority: Medium CC: dneary, maemo, quim.gil
Version: unspecifiedKeywords: easyfix
Target Milestone: ---   
Hardware: All   
OS: All   
URL: http://wiki.maemo.org/Special:Userlogin
Attachments: Screenshot with the login form

Description Ryan Abel (reporter) maemo.org 2008-06-11 13:50:11 UTC
STEPS TO REPRODUCE THE PROBLEM:

1. Logout (if necessary)
2. Pretend that you're a new user who doesn't know that logins are from Garage.
3. Go to the login page, figure you don't have an account (as you've never
created one for this wiki), try to register, but registration form doesn't
work.

EXPECTED OUTCOME:
User should be informed that the login information is from Garage and be
provided a link to the Garage registration page from the mediawiki login page
(see bug's URL field)

ACTUAL OUTCOME:
No indication of the Garage login or registration process is found on the
mediawiki login page, leading to lots of user frustration.

REPRODUCIBILITY:
Always

OTHER COMMENTS:
sysops should seemingly be able to edit this page from within the wiki, but
something in the permissions must have been changed during setup, as they are
unable to. '$wgGroupPermissions['*']['edit'] = false;' was probably set to
false according to this thread:
http://www.mwusers.com/forums/showthread.php?t=6929

So either the file can be edited locally at /includes/SpecialUserlogin.php or
'editinterface' permissions for sysops can be turned on and myself or somebody
else (probably X-Fade) can take care of it.

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US)
AppleWebKit/525.18 (KHTML, like Gecko, Safari/525.20) OmniWeb/v622.1.0.101362
Comment 1 Ferenc Szekely maemo.org 2008-06-16 15:44:50 UTC
The bug will be tackled later today.
Comment 2 Ferenc Szekely maemo.org 2008-06-17 01:14:52 UTC
Fixed: https://wiki.maemo.org/index.php?title=Special:Userlogin

I have edited some of the 'System messages', see Special pages and changed the
SpecialUserlogin.php on the server. AFAIK it is not possible to edit the login
page from within the wiki. You can only edit 'Special messages', but you can't
for example edit the link that was 'under' the 'Create account' text in the
original code.

This is a hack. I wanted to avoid changing the original code. Not an elegant
solution. I would have preferred an extension to the original login form and
have a box 'New here' (or similar) just like the current 'Log in' box. Within
this box we could have explained more why the user registration happens at
garage. I did not manage to create such extension quickly (I am not a mediawiki
expert atm).

I will return to this problem later, but for now I am marking it fixed.
Comment 3 Ryan Abel (reporter) maemo.org 2008-08-24 21:23:27 UTC
Not sure when things changed, but it appears that the notice is now gone.

http://wiki.maemo.org/index.php?title=Special:Userlogin

Reopening. . . .
Comment 4 Quim Gil nokia 2008-11-04 23:56:50 UTC
Demoted to Medium as agreed on the
http://wiki.maemo.org/Maemo.org_Sprints/November_08 meeting.
Comment 5 Niels Breet maemo.org 2009-01-05 17:39:03 UTC
Can't reproduce the problem. The link to garage (notice) is there. I guess this
problem was due to the proxy that was in front of http before.
Comment 6 Ryan Abel (reporter) maemo.org 2009-01-06 07:22:32 UTC
Hrm, I see no mention of needing a maemo.org account or link to a registration
page on http://wiki.maemo.org/Special:Userlogin,
https://wiki.maemo.org/Special:Userlogin,
https://wiki.maemo.org/index.php?title=Special:Userlogin, or
https://wiki.maemo.org/index.php?title=Special:Userlogin.
Comment 7 Dave Neary maemo.org 2009-01-06 12:33:31 UTC
(In reply to comment #6)
> Hrm, I see no mention of needing a maemo.org account or link to a registration
> page on http://wiki.maemo.org/Special:Userlogin,
> https://wiki.maemo.org/Special:Userlogin,
> https://wiki.maemo.org/index.php?title=Special:Userlogin, or
> https://wiki.maemo.org/index.php?title=Special:Userlogin.

Right there above "You must have cookies enabled to log in to maemo.org wiki",
there's "Don't have a login? <a
href="https://garage.maemo.org/account/register.php">Please create an account
at garage.maemo.org.</a>"

You don't see it?
Comment 8 Daniel Martin Yerga 2009-01-06 13:04:54 UTC
Created an attachment (id=1089) [details]
Screenshot with the login form

(In reply to comment #7)
> You don't see it?

No.
Look the screenshot. It's for http://wiki.maemo.org/Special:Userlogin but it's
the same with the other links Ryan mentioned.
Comment 9 Dave Neary maemo.org 2009-01-06 13:39:44 UTC
> No.
> Look the screenshot. It's for http://wiki.maemo.org/Special:Userlogin but it's
> the same with the other links Ryan mentioned.

Thanks for the screenshot - weird! Is this an Iceweasel only issue? Is the
relevant text there if you view the page source, and hidden with CSS?

Re-opening bug until we figure out the cause.
Comment 10 Niels Breet maemo.org 2009-01-06 14:06:14 UTC
I found the issue. Because we have our own authentication module, account
creation is disabled. The original code only showed the extended message when
account creation was enabled.

So in the end I had to make a one line fix to always show the account creation
message.