Bug 2942

Summary: allow filtering of list of applications
Product: [Maemo Official Applications] Settings and Maintenance Reporter: maemo
Component: Application managerAssignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: application-manager-bugs
Severity: enhancement    
Priority: Medium CC: andre_klapper, quim.gil
Version: 4.0   
Target Milestone: ---   
Hardware: All   
OS: Linux   

Description maemo (reporter) 2008-02-14 21:31:54 UTC
SOFTWARE VERSION:
2.2007.50-2

As the list of available applications grows, it becomes more difficult to
browse, even if the user selects pre-defined categories. A simple filtering
system would make it much easier to find the desired applications. For example,
the two most obvious filters would be:

    Show only applications that have been changed or added since the last
    repository refresh.


    Hide all "library" applications. These are very rarely installed or removed
    independently, and it's much better (particularly for novice users) to
    surpress the display of these packages.



OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.10)
Gecko/20071128 Microsoft/1.5.2 Firefox/1.5.2
Comment 1 Jussi Kukkonen 2008-02-15 00:37:40 UTC
(In reply to comment #0)
The first suggestion is a good one. Second one confuses me:

> Hide all "library" applications. These are very rarely installed or removed
> independently, and it's much better (particularly for novice users) to
> surpress the display of these packages.

This is how it currently works. Any libraries that are visible in Application
Manager are bugs and should be filed as such in appropriate places.

The exception is "red pill" mode in Application Manager. There library packages
are shown on purpose.
Comment 2 Daniel Martin Yerga 2008-07-20 16:47:13 UTC
IMHO, this bug would be INVALID+DUPLICATE ;)

INVALID for the second request as Jussi mentioned, it's how currently work.

DUPLICATE for the first request, there is two possible bugs with this feature
request: 
https://bugs.maemo.org/show_bug.cgi?id=1282
https://bugs.maemo.org/show_bug.cgi?id=2900
Comment 3 Andre Klapper maemo.org 2008-07-21 13:21:39 UTC
Thanks Daniel. :-)

1) This is bug 1282, hence marking as duplicate.
2) In Diablo libraries are hidden in the App manager.

*** This bug has been marked as a duplicate of bug 1282 ***
Comment 4 Ryan Abel maemo.org 2008-07-21 13:44:03 UTC
(In reply to comment #3)
> 2) In Diablo libraries are hidden in the App manager.
> 

Actually, stuff outside of User/ has always been hidden by default in the
Application manager (Red Pill disables this), any libraries appearing in
Application manager are to blame on bad packagers.
Comment 5 Andre Klapper maemo.org 2008-07-21 13:46:14 UTC
(In reply to comment #4)
> Actually, stuff outside of User/ has always been hidden by default in the
> Application manager (Red Pill disables this), any libraries appearing in
> Application manager are to blame on bad packagers.

Interesting. Then Chinook was completely broken for me. Anyway, this is past.
:)