Bug 2621

Summary: Finger keyboard does not launch with finger tap
Product: [Maemo Official Platform] Desktop platform Reporter: Noah Mittman <noah>
Component: Virtual keyboard (fullscreen)Assignee: unassigned <nobody>
Status: RESOLVED DUPLICATE QA Contact: vkb-bugs
Severity: normal    
Priority: High CC: shija03, tomas.junnonen
Version: 4.0   
Target Milestone: 4.1   
Hardware: N800   
OS: Maemo   

Description Noah Mittman (reporter) 2007-12-21 20:03:25 UTC
STEPS TO REPRODUCE THE PROBLEM: Tap text input with finger

EXPECTED OUTCOME: Finger keyboard appears

ACTUAL OUTCOME: Stylus keyboard appears

REPRODUCIBILITY: always
(always/sometimes/once)

EXTRA SOFTWARE INSTALLED: none, tried immediately after fresh flash of OS2008
2.2007.50-2 after reading report of possible solution on
maemointeraction.wordpress.com.

OTHER COMMENTS:
Comment 1 Noah Mittman (reporter) 2007-12-21 20:24:04 UTC
And yes, the preference is properly set, and I've also recalibrated the screen,
JIC
Comment 2 Noah Mittman (reporter) 2007-12-21 21:32:40 UTC
Sorry, also need to note that this feature worked reliably in OS2007 and
intermittently in OS2008 Beta.
Comment 3 Snak 2007-12-22 08:56:39 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Snak 2007-12-22 08:59:36 UTC
It should probably say double tap. I tap the edit box once with my finger to
select it, then have to double tap it again to get finger board. Why not have
it how it used to - a single tap detects my huge finger and loads it up when i
first select the edit box? Or at least have the option for it
Comment 5 Roope Rainisto nokia 2007-12-26 13:23:54 UTC
Have you found any differences in this behaviour in different applications?
i.e. is this behaviour specific for instance to the search applet on the Home
view, or does it behave similarly also in the Notes application, or in a text
input field in the Browser?
Comment 6 Snak 2007-12-29 10:53:39 UTC
Applications tested;
Google bar on desktop
Google search bar in web browser home
Skype instant messaging
Email text box (in account setup)

On all cases the text box requires it to be already selected before the finger
tap works (thus, annoyingly, requiring 2 well placed taps in total). Where as
it used to be a single finger tap regardless of if it were selected or not
would bring up the finger board. This is particularly annoying in skype instant
messaging, where the initial finger tap brings up the small miniboard and the
miniboard moves the edit box position upwards. This means you have to then tap
in a different place in order to open the finger board.

There is also a small issue that on the second finger tap to bring up the
finger board, occaisionally didnt bring up the finger board. I put this down to
the sensitivty of the equipment not detecting my finger tap.

Can I suggest an more options to customize this and make it user friendly, for
example;
-A single finger tap brings up the finger board even if its not selected
-Make the finger board the default keyboard (dont use the smaller one)
Comment 7 Roope Rainisto nokia 2008-01-02 10:22:41 UTC
Adding CC - Tomas, would you care to comment? I've heard this now from quite
several sources.
Comment 8 Kees Jongenburger 2008-01-07 09:11:50 UTC
entered a bug in the skype developers bugtracker... perhaps this will help

Don't be afraid to vote/comment :p

https://developer.skype.com/jira/browse/SCL-306
Comment 9 shija03 2008-04-05 17:26:31 UTC
I don't think it was the OS2008, but rather the applications that were added to
the OS2008 after the base install.  Everything was working fine, until I
started installing other Apps - VNC, OpenVPN, OpenSSH, RDesktop...  Basically
none of them should have anything to do with the keyboard input, but I think
there should be an option to reinstall the libraries that makes the Keyboard
app and simply do an /etc/osso-af-init/keyboard.sh stop and start.
Comment 10 webmaster 2008-06-04 23:22:52 UTC
It's very, very, unreliable at best.  It should at least work well in MicroB.
Comment 11 Ryan Abel maemo.org 2008-06-05 00:59:33 UTC
This works fine in Diablo again.
Comment 12 Ryan Abel maemo.org 2008-06-05 01:07:25 UTC
Apologies for the bugspam, found the appropriate earlier bug after I resolved.

*** This bug has been marked as a duplicate of bug 1629 ***