Bug 2568

Summary: Menu icons for newly installed software are not shown at correct size before reboot
Product: [Maemo Official Platform] Desktop platform Reporter: Andrew Flegg <andrew>
Component: Application MenuAssignee: unassigned <nobody>
Status: RESOLVED WORKSFORME QA Contact: task-navigator-bugs
Severity: normal    
Priority: Low CC: andre_klapper, eero.tamminen, lucas.rocha
Version: 4.0   
Target Milestone: ---   
Hardware: All   
OS: Linux   

Description Andrew Flegg (reporter) maemo.org 2007-12-15 16:35:34 UTC
STEPS TO REPRODUCE THE PROBLEM:
1) Install mplayer from the Application Manager, after adding the extras-devel
repository.
2) Open the task navigator's application menu once it is installed.
3) Open the "Extras" category.

EXPECTED OUTCOME:
mplayer has a full-size icon.

ACTUAL OUTCOME:
mplayer has a small icon. Reboot the device, and repeat steps 2-3, mplayer has
a full-size icon.

REPRODUCIBILITY:
always (has happened with MPlayer, Canola2 and Maemopad+)

OTHER:
This has been tested with OS2008 v1.2007.42-18 on an N810. Other versions of
OS2008 have not been tested for this behaviour.
Comment 1 Andre Klapper maemo.org 2008-11-03 23:35:33 UTC
Installed mplayer on N810, 4.2008.36-5.
Couldn't reproduce this, icon size is correct in Extras submenu.
Andrew, if this is still an issue for you, please reopen.
Comment 2 Eero Tamminen nokia 2008-11-04 09:46:00 UTC
> EXPECTED OUTCOME:
> mplayer has a full-size icon.
>
> ACTUAL OUTCOME:
> mplayer has a small icon. Reboot the device, and repeat steps 2-3,
> mplayer has a full-size icon.
>
> REPRODUCIBILITY:
> always (has happened with MPlayer, Canola2 and Maemopad+)

Isn't this a bug in those applications as they don't provide TN with a
correctly sized icon?
Comment 3 Andrew Flegg (reporter) maemo.org 2008-11-04 11:21:40 UTC
(In reply to comment #2)
> 
> Isn't this a bug in those applications as they don't provide TN with a
> correctly sized icon?

I don't see how: rebooting the device shows the full size icon and I've seen
this intermittently with many different applications.
Comment 4 Eero Tamminen nokia 2008-11-04 11:59:23 UTC
This is a new icon with new name, not something that existed before
installation, only in smaller size?

And they're refreshing the icon cache (after installing new icon, but before
installing the .desktop file) correctly?