Bug 2566

Summary: No "Maps" application component in "Applications" (Connectivity:Location Framework)
Product: [Websites] maemo.org Website Reporter: Andrew Flegg <andrew>
Component: BugzillaAssignee: Maemo QA (deprecated) <qa>
Status: VERIFIED FIXED QA Contact: Ferenc Szekely <bugzilla>
Severity: normal    
Priority: High CC: andre_klapper, jake.kunnari, quim.gil, sven
Version: 4.0   
Target Milestone: ---   
Hardware: All   
OS: Linux   
Bug Depends on: 3733    
Bug Blocks: 2567    

Description Andrew Flegg (reporter) maemo.org 2007-12-15 16:28:40 UTC
STEPS TO REPRODUCE THE PROBLEM:
1) Try to raise a bug in the "Maps" application, bundled with OS2008, in
Bugzilla.

EXPECTED OUTCOME:
"Applications" product contains a "Maps" component.

ACTUAL OUTCOME:
There is no suitable location for raising the bug.

REPRODUCIBILITY:
always
Comment 1 Jake Kunnari 2008-01-22 10:20:00 UTC
Quim added to cc-field
Comment 2 David Hagood 2008-02-05 19:18:04 UTC
I realize that the Maps app is done by Wayfinder, not Nokia, but it would be
nice to have a way to pass features/bugs/map errrors/map oversights on to
Wayfinder.
Comment 3 Quim Gil nokia 2008-02-08 08:46:15 UTC
This has a lot to do with the definition of the scope of this bugzilla -
something I'm working on but takes time since has to do with the maemo
strategy, the community <---> Nokia <---> partners complicated triangle...

Let's do something. Let's create a Location component (or a better name if you
find it) since we don't have a bugzilla component for the location framework -
and this is something related to the platform itself. Users can file bugs about
Maps there, and then the maintainers of the component (Jake, you have to find
someone) will decide whether this is something they take, they forward or they
wontfix.

My chink is done. Reassigning to Jake.
Comment 4 Jake Kunnari 2008-02-11 11:16:18 UTC
Location Framework component created.
Comment 5 timeless 2008-02-11 11:24:11 UTC
https://bugs.maemo.org/describecomponents.cgi?product=Connectivity#Locaiton%20Framework
Location Framework
location framework related bugs (GPS, Maps...)
Comment 6 Jussi Kukkonen 2008-02-29 21:10:37 UTC
*** Bug 2993 has been marked as a duplicate of this bug. ***
Comment 7 Andre Klapper maemo.org 2008-10-02 15:08:59 UTC
Hmm. I still think that the backend (GPS, a-gps = Location framework) is a
totally different issue than the frontend (e.g. Maps = Application).
Need to think about this.
Comment 8 Quim Gil nokia 2008-10-03 10:55:24 UTC
This has to do with the definition of Maemo, the platform, as opposed to the
full software stack shipped in the Nokia devices and also the additional
applications Nokia develops on top of that.

As for today Maps is not an intrinsycal part of Maemo and I haven't been able
to get the commitment from the project developing it (outside of the Maemo
team) to follow the bugs here. The same might happen with other (closed source)
applications developed elsewhere. With the current setting it is basically up
to you guys to create the components for those or not, knowing the
circumstances.

I rather concentrate my efforts improving the workflow with the Nokia teams
developing the Maemo platform AND compatible open source applications.