Bug 2554

Summary: Add "Move to folder" button in main view
Product: [Maemo Official Applications] Email Reporter: Josh Triplett <josh>
Component: GeneralAssignee: modest-bugs
Status: RESOLVED WONTFIX QA Contact: modest-bugs
Severity: enhancement    
Priority: High CC: andre_klapper, carsten.munk, dyerga, ext-mox.soini, maemo, quim.gil
Version: 4.1.2 (4.2008.36-5)Keywords: community-diablo, patch
Target Milestone: 5.0 (1.2009.41-10)   
Hardware: N800   
OS: Linux   
Bug Depends on:    
Bug Blocks: 2585    
Attachments: Move to folder in modest toolbar

Description Josh Triplett (reporter) 2007-12-15 03:35:04 UTC
When viewing a single email, Modest provides a "move to folder" button in the
toolbar.  Please provide the same button in the main view.  This would allow a
consistent interface for organizing mails, and allow moving multiple mails at
once.
Comment 1 Andre Klapper maemo.org 2008-09-30 17:11:22 UTC
Right, this is currently only available through the menus.

Would a shortcut (like Control+M) also work for you to fix this?
Comment 2 Daniel Martin Yerga 2008-09-30 17:23:20 UTC
(In reply to comment #1)
> Right, this is currently only available through the menus.
> 
> Would a shortcut (like Control+M) also work for you to fix this?
> 

The problem is when you haven't a keyboard (for example with a N800).

I have a patched modest with 'move to folder' button in the toolbar (very
useful for me), it's only four lines added to the code, but I imagine it would
break the UI specification ;)
Comment 3 Andre Klapper maemo.org 2008-09-30 17:57:14 UTC
Argh, I always forget about the N800. I'm very sorry. Need more hardware. ;-)
Want to share that patch here?
Comment 4 Josh Triplett (reporter) 2008-10-01 09:40:39 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Right, this is currently only available through the menus.
> > 
> > Would a shortcut (like Control+M) also work for you to fix this?
> > 
> 
> The problem is when you haven't a keyboard (for example with a N800).

Right; I have an N800, so a keyboard shortcut would not work here.

> I have a patched modest with 'move to folder' button in the toolbar (very
> useful for me)

Awesome!  I'd really appreciate having that as well.
Comment 5 Josh Triplett (reporter) 2008-10-01 09:42:21 UTC
Also see bug 2585, which I think might address one of the most common uses of
moving to a folder.
Comment 6 Daniel Martin Yerga 2008-10-02 00:53:55 UTC
(In reply to comment #3)
> Argh, I always forget about the N800. I'm very sorry. Need more hardware. ;-)
> Want to share that patch here?
> 

Of course, let me until the weekend, the 14 hours out of home in weekdays
aren't helping me with my hobbies ;)

(In reply to comment #4)
> Awesome!  I'd really appreciate having that as well.
> 

Josh, I have uploaded a .deb package to Internet Tablet Talk forums, with some
changes as this bug and also bug 2553 and bug 2583. I haven't the link handy
but if you search in ITT for "modest move toolbar" could go out the right
thread.
Comment 7 Daniel Martin Yerga 2008-10-05 15:33:56 UTC
Created an attachment (id=953) [details]
Move to folder in modest toolbar

Adding the promised patch ;)

It adds the "Move to folder" function to the main window toolbar. It wasn't
very difficult to do, because this option is available in other windows (for
example in the message view window).

The only problem here is perhaps there are too icons in the main window
toolbar, but well for me isn't problem, and I only use the fingers using
modest.
Comment 8 Andre Klapper maemo.org 2008-10-09 11:25:10 UTC
Main window and message window both have 6 buttons, but that's not an argument
to not make this available - file manager has 7.

This won't go in for Diablo (UI frozen), but I'm going to push for Fremantle.
Comment 9 Andre Klapper maemo.org 2008-10-14 13:22:23 UTC
I was told by Nokia that there's currently no definite answer to this
enhancement for Fremantle because some UI changes are considered.

Hope to be able to update the status here in a few weeks and give you an
answer.

Setting target to Fremantle so I won't forget.
Comment 10 Daniel Martin Yerga 2008-10-14 23:21:00 UTC
(In reply to comment #9)
> I was told by Nokia that there's currently no definite answer to this
> enhancement for Fremantle because some UI changes are considered.
> 
> Hope to be able to update the status here in a few weeks and give you an
> answer.
> 
> Setting target to Fremantle so I won't forget.
> 

Thanks Andre :)
Comment 11 Quim Gil nokia 2008-12-30 00:43:14 UTC
Time for an update? Are the Modest developers aware of this patch?
Comment 12 Andre Klapper maemo.org 2008-12-30 01:29:08 UTC
(In reply to comment #11)
> Time for an update? Are the Modest developers aware of this patch?

At least they were, don't know if they still are. :-)

CC'ing Mox as he told me in October that "there's no definite answer to this
enhancement at the moment".
Should be easier to make a decision about this patch now that some time has
passed.
Comment 13 Mox nokia 2009-01-07 15:25:50 UTC
Hi, my understanding is that there were some Fremantle related UI changes in
Modest which effectively resulted in that there's no toolbar at all for this
situation.

So unfortunately the patch and this bug are not relevant anymore in Fremantle,
sorry.
Comment 14 Quim Gil nokia 2009-01-07 15:55:59 UTC
Resolving as WONTFIX, then.

- The patch won't be taken officially for Diablo. Although since Modest is
moving to open development it could well taken ín a potential community
version.

- According to Mox, the issues that caused this enhancement request are FIXED
in Fremantle through a more radical improvement of the UI. 

Sadly we can't share UI examples at the moment. Feel free to reopen this
request if you still find an issue when the Fremantle Modest is public.
Comment 15 Andre Klapper maemo.org 2009-05-08 18:49:44 UTC
Adding Stskeeps - patch might be interesting for Mer.
Comment 16 Lucas Maneos 2009-10-22 07:56:45 UTC
Marking patches of interest to Diablo (Maemo4) community updates, please excuse
the noise.