Bug 2481

Summary: User Karma is not updated
Product: [Websites] maemo.org Website Reporter: Andrea Grandi <a.grandi>
Component: ProfileAssignee: Henri Bergius <henri.bergius>
Status: RESOLVED FIXED QA Contact: profile-bugs
Severity: major    
Priority: High CC: andrew, andre_klapper, dneary, dufkaf, jamie.bennett, quim.gil, rabelg5
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: Linux   

Description Andrea Grandi (reporter) 2007-12-04 12:05:25 UTC
STEPS TO REPRODUCE THE PROBLEM:

I usually write mails in both mailing list, I write review of applications in
garage and I vote as favourite some news.

EXPECTED OUTCOME:

Increased karma

ACTUAL OUTCOME:

Karma is not increased.

REPRODUCIBILITY:

Always

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

Could it be some problems with my user? The user is andy80
Comment 1 Quim Gil nokia 2007-12-04 12:18:43 UTC
Let's see. These are my values today:

Karma      1521
Software     27
Bugs     512
Wiki     36
News     537
Discussion     292
Comments     30
Rating     87

and these are yours:

Karma      25
Software     3
Bugs     0
Wiki     0
News     9
Discussion     12
Comments     0
Rating     1.25

(feel free adding more, so we can track them)

Can you please follow in the next days and see if both values are static/moving
or just one?
Comment 2 Andrea Grandi (reporter) 2007-12-04 12:23:06 UTC
Yes Quim, I can track them again. Anyway I noticed this are the same values
that were restored from backup few days ago. I'll try to review some other
application and to add some Favourites, to see if Karma is updated in the next
days.
Comment 3 Andrea Grandi (reporter) 2007-12-06 14:49:08 UTC
Hi all,

after two days, Karma is updated in this way:

Karma      97
Software     3
Bugs     12
Wiki     0
News     -5
Discussion     38
Comments     22
Rating     3.75

I don't know if values are exact or not. Can anyone please verify them?
Comment 4 Andrea Grandi (reporter) 2007-12-06 19:10:44 UTC
A thing I didn't notice: why the "News" section is -5 ? How is it calculated?
Thanks.
Comment 5 Quim Gil nokia 2007-12-07 08:46:20 UTC
The update of your karma looks sensible. I'd say this is a WORKSFORME.

News: it depends on the news karma, you might get negative values when people
bury your posts.
Comment 6 Jamie Bennett 2008-01-15 23:58:11 UTC
Unfortunately for me this doesn't seem to have been working for a long time
(maybe some kind of username/email/feed address problem). After several 'karma
inducing' actions (at least 3 garage reviews and comments, 1 news item (+2 on
the thumbs up so far), at least one mailing list comment e.t.c in the last 24
hours my karma hasn't moved and it hasn't moved for months. In the last 3
months (that I estimate it hasn't been working for me I have multiple news
items that have hit the front page e.t.c. 

It wouldn't worry me ordinary apart from the fact that it isn't working (for
me) and someone needs to be informed but when I missed out on the developer
code for the n810 and there is talk of certain activities being dependent on
user karma, an active and enthusiastic contributor may miss out on certain
benefits :(

Unfortunately as Quim suggested, I cannot reopen the bug as I'm not the
originator or assignee.
Comment 7 Quim Gil nokia 2008-01-16 07:21:23 UTC
Let's reopen, then.
Comment 8 Jamie Bennett 2008-02-13 00:40:08 UTC
Still nothing?

Any idea's?
Comment 9 eero.afheurlin 2008-02-13 09:56:15 UTC
Given that this works for most people I'd guess for some reason (different
email addresses and/or usernames used in different places ?) the user matching
isn't working quite right for you.

Henri did the calculations system so reassigning.
Comment 10 Dave Neary maemo.org 2008-05-09 16:18:03 UTC
I can confirm this bug - my karma's been stuck at 3, in spite of numerous blog
posts, bug comments, forum comments and a wiki addition.
Comment 11 Andre Klapper maemo.org 2008-06-10 10:28:35 UTC
same here for me though I've triaged a few bugs now:
http://maemo.org/profile/view/e9f9965887f911dc87038fd356c24c2a4c2a/ - but maybe
it's because of "bugzilla_reported" instead of triaging or closing :-)
Comment 12 Dave Neary maemo.org 2008-06-10 11:58:00 UTC
I'm still stuck on 3 as of today.

Dave.
Comment 13 Quim Gil nokia 2008-06-13 13:52:58 UTC
Increasing severity. Not only we are carrying this bug for too long, but also
it is becoming relevant since we want to consider user karma as one of the
factors to be sponsored to participate in the maemo summit.
Comment 14 Henri Bergius 2008-06-13 14:58:15 UTC
Using Dave as the test case, it seems the nightly recount has been timeouting
due to the number of users karma needs to be counted for.

I've disabled PHP timeouts for the script and am just making new test runs.
Comment 15 Dave Neary maemo.org 2008-06-13 15:49:37 UTC
Yay! Karma says 138!

Does this make me worthy? :)

http://maemo.org/profile/view/dneary/

Dave.
Comment 16 Henri Bergius 2008-06-16 14:22:22 UTC
I've now confirmed that karma "stuckness" was because of cron timeouts. Some
fixes done:

* PHP time limitations removed from the script
* Cron runs are now run without Squid in between to remove that possibility of
timeout

Now at least karmas of the people reporting here have changed (multiple times
over weekend in Dave's case), so marking this fixed.
Comment 17 Mikko Vartiainen 2008-08-13 17:27:06 UTC
I think that this bug should be reopened.

I have submitted couple of games to maemo.org/downloads, first one is here:
http://maemo.org/downloads/product/OS2008/blobwars/

None of the games show up in my profile page:
http://maemo.org/profile/view/mikkov/
Comment 18 Frantisek Dufka maemo.org 2008-08-13 17:43:49 UTC
OK, I am reopening this bug. My "Discussion" karma is stuck at 6
http://maemo.org/profile/view/fanoush.html
If this should reflect posts to mailing list I should get a little bit more
than that (since 2005 :-). Most probably it is related to bug #2212 - until
that bug was fixed my single email was not the one I used for mailing lists. I
added that mail after #2212 was resolved but my 'Discussion' karma does not
increase.
Comment 19 Henri Bergius 2008-08-14 15:32:51 UTC
It seems many of the heavier runs (like karma recount) now fail because the
server is seriously overloaded. It has been going gradually worse since
MediaWiki was installed.

Things will be better as soon as the new servers are installed. But apart from
moving Wiki to another server as a "quick fix", there are few ways to solve
this.
Comment 20 Henri Bergius 2008-08-14 16:04:36 UTC
Light at the end of the tunnel: Seems like ISP had moved the servers, and in
the process activated some watchdog script that was going awry. This meant
Apache was getting killed every minute, and so any longer script (or
badly-timed page load) would be aborted.

Obviously heavy operations like Karma were affected. I'm running a manual
recount now, and from now on cron should again start doing this.
Comment 21 Andrew Flegg maemo.org 2008-09-05 22:48:23 UTC
Unfortunately, this is back.

My karma has been stuck on 660 for a week or two now, despite:

* Contributing to a variety of maemo-* threads
* Rating /news/
* Getting favourites on my blog posts.

GeneralAntilles has reported the same. It seems unlikely we've both plateaued
at the same time ;-)
Comment 22 Ryan Abel maemo.org 2008-09-05 22:50:38 UTC
(In reply to comment #21)
> GeneralAntilles has reported the same. It seems unlikely we've both plateaued
> at the same time ;-)
> 

Yes, my discussion karma in particular seems a bit date.
Comment 23 Henri Bergius 2008-09-08 20:36:21 UTC
Seems karma count (or some other daily MidCOM cron script) had crashed badly
(or maybe there was a reboot?) on Aug 25th, leaving the pid file in place.

-rw-r--r--  1 root        root           6 2008-08-25 14:03
midcom_services_cron_day.pid

Removed it and restarted daily cron.
Comment 24 Simon Pickering maemo.org 2008-09-10 17:40:35 UTC
My discussion karma seems to have fallen off a cliff (now 8 points, I note qgil
has 6 points). Seems pretty low assuming it includes mailing list posts?

I'm also both missing Garage projects as well as doubled up on some in the
Groups listing.

Lastly, which particular subheading do wiki entries (creates/edits?) affect?
Are kudos points which may have been created by work on the previous wiki
affected for pages which have been migrated? (fair enough if I lose all the
points because I should have migrated it myself I suppose ;)
Comment 25 Simon Pickering maemo.org 2008-09-10 17:47:22 UTC
> I'm also both missing Garage projects as well as doubled up on some in the
> Groups listing.

Actually the doubling up is not strictly true so you can probably ignore that.
E.g.:

# DSP OGG Vorbis decoder
# DSP OGG Vorbis decoder members

I suppose the first one is because I created the project, in which case fine.

Still, I at least am missing two more project which I started (and am also a
member of ;)
Comment 26 Frantisek Dufka maemo.org 2008-09-10 18:29:11 UTC
(In reply to comment #24)
> My discussion karma seems to have fallen off a cliff (now 8 points, I note qgil
> has 6 points). Seems pretty low assuming it includes mailing list posts?

This may be related to changes done for fixing bug #2212. My discussion karma
raised from 6 to 1406. Maybe the pool of karma points is exhausted? ;-)
Comment 27 Ryan Abel maemo.org 2008-10-15 23:33:36 UTC
Karma seems to be kaput again, mine hasn't updated in at least a week.
Comment 28 Jamie Bennett 2008-10-15 23:37:29 UTC
Not wanting to kick a dieing horse but mine hasn't moved too despite lots of
blogs, discussion and other contributions.

Something to do with the server move?
Comment 29 Henri Bergius 2008-10-29 12:02:07 UTC
After some auditing, the problem is simply that the growth in maemo.org user
numbers has gotten to the stage where at some point the Karma recalculation
script simply runs out of memory.

To fix this, the karma recount has been now changed to run every hour, but run
for only N users that have been modified the earliest. With this change we can
tune the number of users to count per hour, and so decide whether full karma
recount cycle should complete in one day, or for example two.

http://trac.midgard-project.org/changeset/18492

This fix can be deployed in two different ways:

* We get it automatically when the servers are upgraded to Ragnaroek (soon)
* It is backported to MidCOM 2.8 so it can be installed immediately
Comment 30 Ryan Abel maemo.org 2008-10-29 12:24:23 UTC
(In reply to comment #29)
> * We get it automatically when the servers are upgraded to Ragnaroek (soon)
> * It is backported to MidCOM 2.8 so it can be installed immediately
> 

We can probably just wait for the big upgrade. There's nothing going on right
now dependent on accurate karma counts.
Comment 31 Henri Bergius 2008-10-29 13:17:19 UTC
The new karma counter has been backported and deployed on the server today. We
will monitor the progress for next couple of days.

With current setup (300 per hour) it should complete recount in two days.
Comment 32 Andrew Flegg maemo.org 2008-10-31 14:41:49 UTC
Is this new counter still recalculating the whole lot every time? If so, will
the karma value keep its value during the recalculation, and only visibly
update when that user's is finished?

Or is the intermediary value held and exposed?