Bug 2299

Summary: Display news item excerpts not just headlines
Product: [Websites] maemo.org Website Reporter: Roger Sperberg <rsperberg>
Component: NewsAssignee: Niels Breet <maemo>
Status: RESOLVED FIXED QA Contact: news <news>
Severity: enhancement    
Priority: High CC: maemo, quim.gil
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: Windows   

Description Roger Sperberg (reporter) 2007-11-16 17:51:17 UTC
EXPECTED OUTCOME:
All the news items from the internettabletalk.com feed provide a short excerpt
describing what the item is about. This excerpt as well as the headline should
be shown at maemo.org (or the whole item, the same as planet.maemo).

ACTUAL OUTCOME:
Only a headline is displayed, without any contextual information.

STEPS TO REPRODUCE THE PROBLEM:

OTHER COMMENTS:
Since I come to this particular point from having been posting about karma, I
should add that it's hard to choose such an entry as a fav when there's really
nothing at maemo.org to base that on. Instead, someone would have to revisit
the ITT news feed page specifically to click on the fav heart. 

Other bloggers get the opportunity to get those fav clicks based on the
readers' immediate response. Unfair! :-)
Comment 1 Roger Sperberg (reporter) 2007-11-16 19:25:01 UTC
I wanted to note this:

If planet.maemo.org is an aggregating site, enabling users to see all the
information in one place, you should treat the ITT and WOM World feeds from the
aggregating perspective, and show enough information that enables users to
decide when they need to leave maemo.org to find out more. A "Headlines only"
approach forces users to leave maemo.org on too little information.
Comment 2 Quim Gil nokia 2007-11-19 08:44:03 UTC
Hi, I have removed "ITT" from the title since this is a good suggestion not
just for http://maemo.org/news/internet_tablet_talk/ but also for the rest of
news sections: 

http://maemo.org/news/announcements/
http://maemo.org/news/community/
http://maemo.org/news/tableteer/

Planet is an exception and it shows the full posts just because this is what a
Planet is supposed to do. 

For the rest excerpts are enough imo and it is good that we encourage to meet
the sources for the full content.
Comment 3 Roger Sperberg (reporter) 2007-11-19 21:13:07 UTC
I would disagree in several respects, from the user standpoint.

You can decide not to include the full content, but a headline is insufficient
to indicate whether one wants to leave the maemo.org site to go to some other
page.

At the least, the feed ought to include the excerpt as well as the headline. I
specifically include both ITT and WOM World in this.

I can understand why you wouldn't want to put full WOM World articles in Planet
Maemo if they're often not about Internet Tablets. But the excerpt at least
lets one know which ones are useful.

The ITT "news" posts are sometimes news and sometimes just regular blogs
(because both the news page and UT Users blog appear on the front page and in
the same feed). If ITT content needs to be segregated from Planet Maemo for
whatever reason, I think the content type is not different and should be
treated the same. Is it really a bad idea to put such short items up in their
entirety?
Comment 4 Quim Gil nokia 2007-11-20 09:14:00 UTC
I don't see we are disagreeing.  :)

As said in Comment #2 I agree that we should have not only titles but also
excerpts in all feeds (except Planet, that shows full posts).

If you prefer to have ITt content being just plugged in Planet maemo this is
fine to us. We took it out and created an own section to give it more
visibility.

Your choice: own section with excerpts or full posts in planet.
Comment 5 Niels Breet maemo.org 2008-05-07 18:23:36 UTC
I have added excerpts everywhere there was only a title shown. It should look a
lot better and make more sense to the reader of these pages.