Bug 2286

Summary: hearts + thumbs down should be available with article head
Product: [Websites] maemo.org Website Reporter: timeless
Component: NewsAssignee: Niels Breet <maemo>
Status: VERIFIED FIXED QA Contact: news <news>
Severity: enhancement    
Priority: High    
Version: 4.0   
Target Milestone: ---   
Hardware: All   
OS: All   
URL: http://maemo.org/news/planet-maemo/

Description timeless (reporter) 2007-11-15 21:25:25 UTC
STEPS TO REPRODUCE THE PROBLEM:
1. visit planet.maemo.org
2. start reading a long article
3. decide you don't like it
4. scroll down until you reach the next article (this may take a while)
5. discover the article has 0 hearts and many thumbs down

EXPECTED OUTCOME:
1. at least the current rankings should be available at the article's headline.
2. a link to the next article would also be appreciated
3. a hint about the article's length would also be appreciated

ACTUAL OUTCOME:
lots of time wasted reading an article no one liked

OTHER COMMENTS:
i know this feature could negatively affect my articles as they tend to be
long, but that's merely further incentive to make sure they're good :)
Comment 1 Quim Gil nokia 2007-11-16 10:41:03 UTC
It makes sense to have the hearts+thumbs *always* at the top, next to the title
as we are doing already with the announcements:
http://maemo.org/news/announcements/view/new_os2007_he_for_the_nokia_770_with_mozilla_engine_and_memory_corruption_bugfix.html

Link to next article I'd rather not touch anything since this is not so badly
needed (nobody asked before, the planets I use don't have them either, don't
want to add any other UI element unless needed).

Same for wordcount or something.
Comment 2 Niels Breet maemo.org 2008-05-07 17:22:14 UTC
The fav icons are now below the title on the planet articles. 

I don't think we need to change it on pages where we only show excepts. We
might move the whole fav, pubdate, author line below the title for those except
articles. Like on http://maemo.org/news

I'll close this bug, the proposed enhancement can be filed as a separate bug.
Comment 3 timeless (reporter) 2008-05-07 17:59:20 UTC
the rendering w/ noscript is bad. i'll file another bug if you don't fix it
before the next time i read planet :)

verified fixed.