Bug 2121

Summary: cannot add multiple install files (for IT2006 and IT2007)
Product: [Websites] maemo.org Website Reporter: Frantisek Dufka <dufkaf>
Component: DownloadsAssignee: Niels Breet <maemo>
Status: RESOLVED FIXED QA Contact: downloads <downloads>
Severity: enhancement    
Priority: High CC: khertan, maemo
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: All   
URL: https://downloads.maemo.org/product/scummvm/

Description Frantisek Dufka (reporter) maemo.org 2007-10-16 14:52:46 UTC
EXPECTED OUTCOME:
when I mark the app to support more systems I would expect more textboxes to
fill path to .install files to various extra repositories (gregale for 2006,
bora for 2007)
ACTUAL OUTCOME:

Only one link is possible, I have entered
http://repository.maemo.org/extras/dists/gregale/install/scummvm.install
which makes the package uninstallable for IT2007 since it contains bad repo_deb
field.

OTHER COMMENTS:
If there is some solution, please add it to
http://maemo.org/community/application-catalog/developer-manual.html

Alternatively (to having more textfields and paths) can you solve it by
automatically generating one merged .install file with all repo_deb_X lines?
Currently upload mechanism generates separate install files in
http://repository.maemo.org/extras/dists/{sdkname}/install/{projectname}.install
Comment 1 Frantisek Dufka (reporter) maemo.org 2007-10-16 18:09:52 UTC
OK, I have created my own merged install file at
http://fanoush.wz.cz/maemo/scummvm.install
Same workaround is used in mplayer download. Seems to work for both systems.
Still  it would be good to have this generated automatically and have it on
repository.maemo.org site, not some external one.
Comment 2 Niels Breet maemo.org 2007-10-18 14:48:55 UTC
This problem will be fixed in the next application catalog update. An
application will have a different entry per OS, so you can point to a different
.install file.
Comment 3 Ferenc Szekely maemo.org 2007-10-19 11:40:54 UTC
As Niels said it will be fixed when the new catalog goes live. There will be an
option for 'editable install file' too. Expected launch is next week (if all
tests go fine).
Comment 4 Ferenc Szekely maemo.org 2007-11-06 19:30:29 UTC
in the new app catalog you can enter an application into each app catalog
(OS2006, OS2007 and OS2008). yes, this means you have to edit 3 places if your
app supports all OSes, but that's what we have. hope it doesn't make life
miserable. beside that we have the fancy editable install feature that works in
chinook, or OS 2008. so you can add repositories which contain dependencies to
your app. i mark this as FIXED, but please reopen if i misunderstood you.
Comment 5 Frantisek Dufka (reporter) maemo.org 2007-11-12 15:24:35 UTC
(In reply to comment #4)
> yes, this means you have to edit 3 places if your
> app supports all OSes, but that's what we have. hope it doesn't make life
> miserable.

Well, it does make life a bit miserable :-) In my case - scummvm it makes
little sense since the binary deb is actually the same. I tried to make more
pages but the result is not good and reveals some bugs.

Bad thing is that there are separate ratings and comments which is confusing.
There are couple of useful comments in 2007 page that could be interesting also
for 2008 users.

Currently there are 2 or 3 pages  (not sure, this is 1st bug :-) about scummvm

http://downloads.maemo.org/product/OS2007/scummvm/
http://downloads.maemo.org/product/OS2008/scummvm/

the third one is only in the list of games for 2007 page 2 but is not
accessible
http://downloads.maemo.org/OS2007/games/?org_openpsa_qbpager_org_openpsa_products_product_dba_page=2
scummvm is twice there.

The second issue is that when I edit page for scummvm for OS2008 (i.e. click
menu Page->Edit) next page has green OS2007 highlighted on the right even if it
is for 2008. Otherwise it works so maybe it is just cosmetic issue.

It looks like maybe it was not good idea to choose same name for all pages but
I don't know how to name them, they are all scummvm :-) Should I change at
least unix project name in first textbox?

Also the screenshots are not shared so I need to upload them to all. Until now
I have created scummvm pages for 2007 and 2008 and I am a bit tired of this.
And I should still make another one for 2006 which will get yet another empty
set of ratings and comments :-)
Comment 6 Quim Gil nokia 2007-11-20 10:52:32 UTC
This belongs to me now.
Comment 7 Quim Gil nokia 2007-11-20 11:00:05 UTC
*** Bug 2211 has been marked as a duplicate of this bug. ***
Comment 8 Quim Gil nokia 2007-11-20 14:52:41 UTC
So, why we have organized different catalogs for different OS versions:

Pros:
- Different comments per OS version. People tend to talk about bugs in
  their version and OS.
- Different .install file for each OS.
- Different description for application. An application can have FM radio
  support for N800, which doesn't exits in 770(OS2006)
- Different ratings/download counts per OS.
- Different screenshots per OS. So the user can see what it looks like in
  their OS.
- Different changes since last version per OS. (A OS2006 user doesn't care
  that a OS2007 specific change was added?)

Cons:
- A little bit more work to update. (It's not like this changes every day)

Said that, we can discuss about improving the current situation:

- Ways of recycling content so you don't need to do the same action twice.
- Awareness of other OS versions of an application. Offering links to.
- Stating ratings and number of comments in other versions.
Comment 9 Frantisek Dufka (reporter) maemo.org 2007-11-20 15:51:19 UTC
So no second option to have older way of having one page, right? Looks like
with python apps this can be more frequent than just with few SDL apps. With
old way as an option it would be a choice of developer to keep it easy and
share everything or have more separate pages. Rationale for old way:

1. it is easy
2. it may make more sense for the developer to keep user comments  etc.
together due to package nature

(In reply to comment #8)
> Said that, we can discuss about improving the current situation:
> 
> - Ways of recycling content so you don't need to do the same action twice.

Yes, nice addition, not critical. As for screenshots I was surprised only the
first one (alphabetically) is shown in package list, I would expect random
selection. But this is for different bug.

> - Awareness of other OS versions of an application. Offering links to.
> - Stating ratings and number of comments in other versions.

Yes, definitely. That's the main issue IMO. Something like
'This package is also available for OS200x, OS200y, you might check it for
additional information' with links would improve it a lot. Maybe also separate
link near comments (or even merge them for all versions) to prevent duplicates
or empty lists for some specific OS versions

If we really can keep same unix project name for all versions it may be even
easy to implement the relation.

Also some guide for package creators how to handle this and fill the forms
correctly would be nice.
Comment 10 Quim Gil nokia 2007-11-22 08:58:16 UTC
From comment #9

> So no second option to have older way of having one page, right?

Nils, how difficult (i.e. hours) do you think would be to implement this in
addition to the current system? The idea is that developers would have a single
entry point for 2 or more releases (defined with i.e. checkboxes) and
publishing once they would get the separate pages in each catalog.

Note that this would affect the introduction and publishing of data. The
product pages would be anyway separate as they are now.


> 'This package is also available for OS200x, OS200y

This was discussed at some point but it was dropped to concentrate on the
release. Nils, can we confirm that this will be implemented at some point?

Also, let's define what information could be shared about stars and comments
and how to present them. 

> Also some guide for package creators how to handle this and fill the forms
correctly would be nice.

We can offer this information inline, next to each form field.
Comment 11 Niels Breet maemo.org 2007-11-22 10:22:53 UTC
(In reply to comment #10)
> From comment #9
> 
> > So no second option to have older way of having one page, right?
> 
> Nils, how difficult (i.e. hours) do you think would be to implement this in
> addition to the current system? The idea is that developers would have a single
> entry point for 2 or more releases (defined with i.e. checkboxes) and
> publishing once they would get the separate pages in each catalog.
> 
> Note that this would affect the introduction and publishing of data. The
> product pages would be anyway separate as they are now.
> 

I'd have to look into this, forms are handled by midcom. Maybe I can implement
a simple way to copy the content to another OS version with a button that is
only visible to 'authors' of the product. Something like 'Copy this info to
OS2006 version'

> > 'This package is also available for OS200x, OS200y
> 
> This was discussed at some point but it was dropped to concentrate on the
> release. Nils, can we confirm that this will be implemented at some point?

Yes, this is still on the roadmap.

> Also, let's define what information could be shared about stars and comments
> and how to present them. 

This is possible, but a bit tricky as it would need quite a bit of changes to
the underlying comment module. It would need to fetch the comments for multiple
projects and sort them accordingly. The ratings are also cached per product and
that should be rewritten too.

> > Also some guide for package creators how to handle this and fill the forms
> correctly would be nice.
> 
> We can offer this information inline, next to each form field.
> 
Sure, if somebody can write some nice descriptions per field, I will add them
to the form.
Comment 12 Quim Gil nokia 2007-11-22 10:38:40 UTC
I'm not talking about merging comments and stars but about referencing them
somehow... Anyway, perhaops it is enough by now to add those links to the
corresponding product page in different versions.

> if somebody can write some nice descriptions per field

Perhaps most of them can be simply extracted from the former guidelines? Tell
me if you need help on this.
Comment 13 Quim Gil nokia 2007-12-03 08:25:16 UTC
I've done my part clarifying things. Now the ball is in Niels' basket for the
implementation.
Comment 14 Niels Breet maemo.org 2007-12-05 13:06:47 UTC
Adding this to my TODO list.
Comment 15 Paul Gear 2008-01-18 13:19:20 UTC
Please ignore the previous comment - wrong bug.  :-(
Comment 16 Niels Breet maemo.org 2008-02-25 13:58:29 UTC
Links to the same application in different OS versions has been added to the
product page. This change is now active on maemo.org.
Comment 17 Niels Breet maemo.org 2008-04-07 09:51:33 UTC
A few descriptions were added for fields that were confusing. I think we can
close this bug now.