Bug 1970

Summary: fav hearts should be turning red instantly
Product: [Websites] maemo.org Website Reporter: Quim Gil <quim.gil>
Component: NewsAssignee: Henri Bergius <henri.bergius>
Status: RESOLVED FIXED QA Contact: news <news>
Severity: enhancement    
Priority: High CC: jamie.bennett
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: Linux   
URL: http://maemo.org/news

Description Quim Gil (reporter) nokia 2007-09-04 06:18:51 UTC
EXPECTED OUTCOME:

Favoriting items should be reflected instantly in the UI, as people are used
nowadays when using Google Mail or any 'star clicking' function (based on
AJAX).

ACTUAL OUTCOME:

Our process for favoriting news is slow and involves two steps (more if you are
anonymous).

STEPS TO REPRODUCE THE PROBLEM:

1. Log in to http://maemo.org/news

2. Click the heart of news items.

3. You are sent to a page confirming.

4. After confirming you are sent back to the previous page, with your heart in
red.

OTHER COMMENTS:

Skipping the confirmation step would be already an (easy to implement?)
improvement. 

Most users providing feedback about the social news commented on the Ajax
functionality.

I was even thinking that the work flow could go like this:

1. Anonymous user favs item
2. Heart turns red and counts go +1 instantly, making the user happy. They are
though temporary values, a trick while the user identifies himself.
3. Login/register window appears, telling the user that needs to identify in
order to store values to their favorites.

3a. If user identifies, values are stored and available in her Favorites page.
3b. If user don't, values are deleted after... 1h?

Registered users should only see hearts turning red and +1 counts instantly. No
need to extra Favorites confirmation page. Just fav, fav, fav!

Originally reported at http://bugs.maemo.org/show_bug.cgi?id=1815
Comment 1 Quim Gil (reporter) nokia 2007-09-08 20:45:54 UTC
Still thinking about this...

Another thing we could do is to accept anonymous votes as anonymous and prevent
dupes by cookies/session, but they would provide a lower karma value than votes
from registered users.

Anonymous couldn't vote -1, registered could.

This way we get more input from casual visitors and they get a neat first
experience. Perhaps some of them get more interested in the fav thing and at
some point they register.

I was planning to have a page under News explaining the whole fav thing in the
lines of 

Why red hearts matter in maemo news
http://desdeamericaconamor.org/blog/node/393
Comment 2 Quim Gil (reporter) nokia 2008-01-29 11:49:54 UTC
*** Bug 2789 has been marked as a duplicate of this bug. ***
Comment 3 Henri Bergius 2008-03-25 13:49:35 UTC
Fixed by implementing the AJAX favoriting system