Bug 1856

Summary: Entries don't show images
Product: [Websites] maemo.org Website Reporter: Quim Gil <quim.gil>
Component: NewsAssignee: Niels Breet <maemo>
Status: RESOLVED FIXED QA Contact: news <news>
Severity: enhancement    
Priority: High    
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: Linux   
URL: http://maemo.org/news

Description Quim Gil (reporter) nokia 2007-08-19 01:49:11 UTC
The top entries in the news highlights were supposed to show images if the
original post contained images. Now they are only text (unless they come from
the flickr or youtube feeds, of course).
Comment 1 Quim Gil (reporter) nokia 2007-08-26 21:47:36 UTC
It's not only about loosing images, they loose completely the format (italics,
bold, pre, etc).
Comment 2 Henri Bergius 2007-08-29 15:47:29 UTC
There isn't enough space for fully formatted news content, and that wasn't in
the social news design either. Therefore WONTFIXing.
Comment 3 Quim Gil (reporter) nokia 2007-08-30 08:27:46 UTC
Fair enough. Reopening as feature request and you can add it to the retainer
hours (unless it's a huge amount of work).

About the space available, in fact there is more space than in the Planet. As
far as I see, I'm not asking for anything else than Midgard is already doing at
http://planet.maemo.org
Comment 4 Niels Breet maemo.org 2008-05-09 17:57:55 UTC
This has now been implemented. We have 2 configuration options we might want to
play with a bit.

On is the word count before truncation. It is currently at 250 words.

And we have to decide which HTML tags we allow. Currently the list is:
<p><a><img><b><i><strong><pre><ul><li><br>
Comment 5 Niels Breet maemo.org 2008-05-12 13:16:25 UTC
I think we can close this bug now. It seems to work as requested. There is an
image visible on the news page, so that does look ok.

Please ping me if there are settings that need to be changed.