Bug 1697

Summary: Scaling back to 100% in "Fit Width to view" doesn't restore initial layout
Product: [Maemo Official Applications] Browser Reporter: George Kibardin <george-kibardin>
Component: ZoomingAssignee: unassigned <nobody>
Status: RESOLVED WONTFIX QA Contact: browser-zooming-bugs
Severity: normal    
Priority: Low CC: andre_klapper, eero.tamminen, romaxa, tuukka.tolvanen
Version: 4.1.2 (4.2008.36-5)   
Target Milestone: ---   
Hardware: N800   
OS: All   
URL: http://www.gentoo.org/

Description George Kibardin (reporter) 2007-07-19 10:42:31 UTC
1. Set browser into "Fit width" mode (I'm sorry I have Russian menu and I don't
know exactly how it is called in English)
2. Go to, for instance, www.gentoo.org
3. Scale up to 180% (or 240%). Layout changes (columns wraps).
4. Scale back to 100%. Layout doesn't restore to original one.
Comment 1 timeless 2007-07-19 13:48:32 UTC
scalability       porting maemo to devices with different sized screens or just
different hardware capable to do more/less than the 770

the browser is ported to the device. this is just a problem with zooming. The
keyword has a different meaning.

Note: I'd be perfectly happy with you specifying the Russian words as long as
you get the lettering correctly.

I'm guessing you mean en ("Fit width to view"), ru ("По ширине экрана")

If I've gotten the wrong Russian string, please correct me.

I presume that reloading at 100% gives you the right results, please correct me
if I'm wrong. Thanks for your report.
Comment 2 George Kibardin (reporter) 2007-07-19 14:34:46 UTC
(In reply to comment #1)
> scalability     porting maemo to devices with different sized screens or just
> different hardware capable to do more/less than the 770
> 
> the browser is ported to the device. this is just a problem with zooming. The
> keyword has a different meaning.

I'm sorry it looks like I've misinterpreted this keyword

> Note: I'd be perfectly happy with you specifying the Russian words as long as
> you get the lettering correctly.
> 
> I'm guessing you mean en ("Fit width to view"), ru ("По ширине
> экрана")
> 
> If I've gotten the wrong Russian string, please correct me.

"По ширине экрана" is exactly what I'm seeing in the menu.

> I presume that reloading at 100% gives you the right results, please correct me
> if I'm wrong. Thanks for your report.
> 

Yes, you are right, reloading fixes the problem. But it may not be always
convenient to reload.
Comment 3 George Kibardin (reporter) 2007-07-19 15:30:00 UTC
BTW.
On the one hand the idea of rearranging tables in mozilla engine looks better
because, for instance, in opera some pages becomes unreadable after scaling
because a useful content becomes a thin column in the screen center only few
words width. Mozilla engine allows to avoid such a problem. But here we have
another disadvantage - we cannot select appropriate font size when tables get
rearranged.

I have one idea that may make reading articles on such sites more convenient.
Take a look on http://george-kibardin.narod.ru/concept.html and play with three
buttons above the blue rectangle. "Expand" expands rectangle, "Dismiss" removes
it. "Fill" ... you better try it :-)
Comment 4 Oleg Romashin nokia 2007-07-19 20:26:22 UTC
>Yes, you are right, reloading fixes the problem. But it may not be always
> convenient to reload.

I have to check Zoom/FtV reflow order and proper disabling of TRUE_ZOOM mode
when FtV disabled...

Very good and detailed Bug Report, thanks.
Comment 5 Andre Klapper maemo.org 2008-07-17 15:53:30 UTC
Does this still happen in Diablo?
Comment 6 George Kibardin (reporter) 2008-07-17 21:24:51 UTC
Yes, you can reproduce this with gentoo.org
Comment 7 Andre Klapper maemo.org 2008-10-14 13:12:30 UTC
Confirming, only happens in "Fit Width to view" mode.

As far as I've heard the mode is reconsidered for Fremantle and I don't expect
any fixes for Diablo here (different priorities).
Comment 8 Andre Klapper maemo.org 2008-10-21 15:47:46 UTC
I was just told that "Fit Width to View" functionality will be dropped/replaced
for Fremantle.

There won't be any work to fix "Fit Width to View" issues for Diablo anymore,
hence closing as WONTFIX.
Comment 9 Andre Klapper maemo.org 2009-09-07 14:01:56 UTC
Moving Zoom related reports to its own (new) Browser subcomponent.
Sorry for the bugmail noise.