Bug 1645

Summary: Skype volume too low
Product: [X-Graveyard] X-Misdirected Reporter: Nedim Cholich <n800>
Component: UpstreamAssignee: unassigned <nobody>
Status: RESOLVED INVALID QA Contact: skype-bugs
Severity: normal    
Priority: Low CC: andre_klapper, eero.tamminen, mikmach, texrat
Version: 1.0   
Target Milestone: ---   
Hardware: N800   
OS: Maemo   

Description Nedim Cholich (reporter) 2007-07-10 20:51:15 UTC
I tried increasing both system and Skype's volume to maximum. I can still
barely hear the other side. Is there a way to bump the volume a bit. I can hear
the same person fine on Windows Skype.
Comment 1 Randall Arnold 2008-01-09 00:43:33 UTC
This is true for other usage, such as GPS in a car.  Road noise drowns out the
voice directions.

This is NOT a low-priority issue.  Please elevate in importance.
Comment 2 Randall Arnold 2008-02-13 21:12:25 UTC
Any progress on this one?

Don't confuse the low votes with low experience or interest-- MANY, MANY users
are complaining about generally poor volume on the tablets in various blogs and
forums.  It has just been difficult to get them to contribute here.

Some have investigated and discovered that the tablets are physically capable
of much higher volume than they currently exhibit.  This being the case, the
maximum volume simply must be increased.  GPS on the N810 can be unusuable due
to high road noise.  That equates to a nonfunctioning product in the user's
mind.  It is critical that this be resolved soon at the risk of increased poor
public perception (severity of this bug is NOT "normal").  I also think this
bug needs to be recharacterized as a general volume issue, not specific to
Skype.
Comment 3 mikmach 2008-02-19 10:20:20 UTC
There is another bug about volume: in OS2007 (last rev.) you cannot make FM
radio play lower than certain value - which for me is too loud when using canal
earphones. It looks strange, like somewhere some artificial threshold for
"total" volume was set. I will try to explain.

Assume device volume is 0-100, FM radio volume is 0-100. Total volume is 0-200.
Threshold is set to ca. 80. If you set eg. device volume to 20, setting FM
volume to 60 and lower mutes radio.

Media players are OK, only FM radio is affected.
Comment 4 Eero Tamminen nokia 2008-02-19 10:38:20 UTC
> There is another bug about volume: in OS2007 (last rev.) you cannot make FM
> radio play lower than certain value

This is obviously a different issue, please file a separate bug
(and add here the new bug number for reference).
Comment 5 mikmach 2008-02-19 11:04:57 UTC
Bug 2960 also applies to volume.
Comment 6 Randall Arnold 2008-02-19 18:36:23 UTC
mikmach, my apologies-- I apparently was wrong that maemo would want to look at
volume issues as one bug.

Eero, out of curiosity-- why would mikmach's bug be addressed separately?  Is
it because his issue is specific to the control in the FM radio as opposed to
the general volume control for the device?  Anyway, it looks to me that the
implementation of volume control in general is faulty, i.e., it won't go high
OR low enough to suit user needs and expectations.

Also, as I noted earlier, the issue of volume not going high enough is not
limited to Skype.  IMO this bug should be repurposed to a broader scale.
Comment 7 Eero Tamminen nokia 2008-02-19 18:59:08 UTC
> Eero, out of curiosity-- why would mikmach's bug be addressed separately?

It's much better to keep bug reports focused (max volume vs. min volume,
skype vs. fm radio), otherwise the bugs get out of hand (there are bugs
with over hundred of comments that nobody can read through).  If you want
to, there could be a separate metabug that depends from all the volume
related bugs, but as the number of these bugs is currently two, I think
it's enough to just comment about the existence of the other one.


> Also, as I noted earlier, the issue of volume not going high enough is not
> limited to Skype.  IMO this bug should be repurposed to a broader scale.

I understood the original issue that the volume in Skype doesn't get as high
as from other applications, and your comment 1 complains about the general 
device max. volume¬ł or maybe about specific Map application(?) sounds.  If
this is correct, then these are different issues and should be filed
separately.
Comment 8 Randall Arnold 2008-02-20 18:53:11 UTC
I see your point, Eero, and will consider filing a separate bug... but I read
the original Skype comments differently I guess.  The originator says that
boosting both application AND system volume did nothing to improve the
situation.  I have seen similar comments in other forums expressing the same
dissatisfaction with system volume for other applications.  What is obvious
from the complaints is that the system volume limit is too low to be
practical-- not just for Skype, or GPS, but in general.  That's why IMO any
complaint with unacceptably low *system* volume limits should be treated as a
single issue, especially given that system volume governs the device broadly. 
IMO opening multiple bugs for what is ultimately the exact same *root* problem
is counterproductive.  I also still see this as a much more critical issue than
it so far labeled; customers perceive this as a serious (ie, fatal) product
flaw and are returning devices for this reason.  I fail to understand why the
volume limits were set so impractically low in the first place...
Comment 9 Eero Tamminen nokia 2008-02-20 19:04:46 UTC
> The originator says that boosting both application AND system volume did
> nothing to improve the situation. 

The relevant information is whether the resulting volume is lower than
is some/any other application(s).  If yes, then it's Skype specific issue.
If not, then it could be something that cannot be fixed in software
(I don't know).
Comment 10 Randall Arnold 2008-02-22 06:39:12 UTC
Eero, it's true that the point you highlight is relevant, but IMO it's not the
only one that is.  I see the fact that max system volume just isn't enough (for
more than one application reported) as relevant too-- in fact, more relevant
than the point you selected.  But I'll stop there.
Comment 11 Eero Tamminen nokia 2008-02-22 09:52:51 UTC
(In reply to comment #10)
> Eero, it's true that the point you highlight is relevant, but IMO it's not the
> only one that is.

Please don't try to hijack bugs.  This bug (summary and description)
are about "Skype volume too low".

If it would be about system volume, it would say "System volume too low"
+ give several pre-installed applications (such as mediaplayer) as examples
and be filed under System software product.
Comment 12 Randall Arnold 2008-02-26 20:46:58 UTC
Eero, I do not hijack bugs.  I thought my rationale for expansion of this one
was sound and easy to understand.  Apparently I was mistaken, sorry.
Comment 13 Eero Tamminen nokia 2008-02-27 14:15:09 UTC
(In reply to comment #12)
> Eero, I do not hijack bugs.  I thought my rationale for expansion of this
> one was sound and easy to understand.

It's much easier to add bug dependencies or mark them as duplicate
(later when and *if* a common cause is found) than try to handle bug with
dozens of comments of which nobody knows what it eventually concerns
and how it could be reproduced or verified.

(Personally I would file a new bug(s) once best way to trigger certain
issue is found and then mark the earlier vague or meandering bug report
as duplicate.  It saves everybody's time.)


> Apparently I was mistaken, sorry.

No problem, your effort is appreciated!   Just file it as a separate
issue as mentioned in comment 11.  If there's a way to get higher
volume as you mention in comment 2, please give steps for that too.
Comment 14 Eero Tamminen nokia 2008-02-28 17:34:16 UTC
Received some comments on the original bug report:
- The report doesn't state whether the issue is with the loudspeaker
  or headphones.  Headphones could give subjectively more volume,
  but there are government regulations on max volume from headphones
- The report doesn't state what sound volume is expected e.g. by comparing
  it to some other application on the device (GPS sound "should" be OK while
  driving, but Skype sound seems indeed lower)
- The tested Skype version is very old, there have been many bug fixes since
then.
  Would need to be retested with the latest release
Comment 15 Andre Klapper maemo.org 2008-05-26 12:02:24 UTC
This is actually out of our scope and a Skype issue - you may want to contact
Skype itself for this. Closing as INVALID.