Bug 1429

Summary: New tools bar in the homepage
Product: [Websites] maemo.org Website Reporter: Quim Gil <quim.gil>
Component: GeneralAssignee: Niels Breet <maemo>
Status: CLOSED FIXED QA Contact:
Severity: enhancement    
Priority: High CC: nisses.mail, tuomas.kuosmanen
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: Linux   
Attachments: quicknav
sidebar
mockup of the moved bar
eeek

Description Quim Gil (reporter) nokia 2007-05-15 07:49:46 UTC
The current tools bar in maemo.org homepage has some potential problems:

- Some people say it is unnoticed where it is.

- Although others say it is in the way, disrupting.

- Depending on the browser or the user settings it might get a second line,
breaking the design (in fact this is the most important, since it's an
objective bug).

Some people have suggested to place ut under the primary navigation bar, which
makes sense. Andreas, can you please work on:

- A design for the toolbar that integrates well with the primary nav in the
home, and only the home. It should be sopmthing thin since we don't want all
the content going down down (we always have tablet users in mind).

- This design would include nice icons for each tool. We might end up using
these icons in the pages of these tools (to be considered).

Not extremely urgent.
Comment 1 Neil MacLeod maemo.org 2007-05-15 10:32:11 UTC
Why only on the home page? A persistent second level nav of "quick links" would
make a lot of sense to me - it would highlight these pages wherever you were
within the maemo.org site and grant the user quick access to those pages.

Perhaps use a smaller font so it doesn't take up too much vertical space, but a
persistent second level nav might work quite well.

Just a note about having tablet users in mind - some tablet users may be
accessing maemo.org over GPRS/3G connections in which case the addition of
icons (and graphics in general) might not be such a good idea unless they add
real value. All icons/images will do is increase the cost and time to view a
page. I suppose the user could turn off image loading, but unfortunately it's
an all-or-nothing option - a per-site option would be useful, hint hint! :)
Comment 2 Quim Gil (reporter) nokia 2007-05-15 10:40:02 UTC
Thanks for the good ideas. Let's see:

- We need first a solution for the homepage. Andreas, please do this in a way
that could be applied efficiently to secondary pages as well.

- We will discuss the implementation of the tool bar as soon as we have it
designed, to avoid abstract/bizantine debates. I do see the utility but at the
same time I'm concerned about an excess of navigation. We have the column and
in deeper pages i.e. documentation we will have also the wikipedia-like
navigation users can show/hide.

(Could be another of those elements to be customizable for registered users via
profile page)

- I suggested the icons to give visibility to the bar. I agree the bar is more
visible just for the fact of beig atached to the nav bar. Andreas, please come
up with a firt try without icons, let's see how it works. 

However, desktop & tablet+wlan users are our clear preference. If you don't
have wlan connection around perhaps you can wait until checking that bug  ;).
Also, small icons don't add much to the weight of the page, and everybody likes
them if they are well done.
Comment 3 Neil MacLeod maemo.org 2007-05-15 14:03:07 UTC
(In reply to comment #2)
> - I suggested the icons to give visibility to the bar. I agree the bar is more
> visible just for the fact of beig atached to the nav bar. Andreas, please come
> up with a firt try without icons, let's see how it works. 
> 
> However, desktop & tablet+wlan users are our clear preference. If you don't
> have wlan connection around perhaps you can wait until checking that bug  ;).
> Also, small icons don't add much to the weight of the page, and everybody likes
> them if they are well done.
> 

Fair enough - I'm just playing devils advocate. "Unlimited" data plans are
becoming available in Europe although limited and expensive (£3/5Mb) plans are
still common in the UK (ie. O2, my current network provider, until I can
migrate to T-Mobile).
Comment 4 Andreas Nilsson 2007-05-16 14:13:35 UTC
Created an attachment (id=437) [details]
quicknav

Quicknav at the top where the breadcrumb-thing is on the other pages. Easy to
find and looks good.
Comment 5 Andreas Nilsson 2007-05-16 14:14:45 UTC
Created an attachment (id=438) [details]
sidebar

This would work on the other pages as well, could be placed below the regular
sub-navigation for those who want to have it everywhere.
Comment 6 Neil MacLeod maemo.org 2007-05-16 18:53:04 UTC
(In reply to comment #4)
> Created an attachment (id=437) [details] [details]
> quicknav
> 
> Quicknav at the top where the breadcrumb-thing is on the other pages. Easy to
> find and looks good.
> 

I like this a lot (and think it would  be good on all pages!) but would it look
better if it were centered?
Comment 7 Quim Gil (reporter) nokia 2007-05-16 23:26:35 UTC
I agree something centered would perhaps look better.

On the other hand, I believe we need an appearance of bar for this bar.
Otherwise it looks in the same way as content: blue fonts on top of the white
sheet, same as news header.

At the end the solution is perhaps simply moving the current bar to the top...

Tuomas, what do you think?

About the right column thing, might be an option for the future when people can
select customized blocks. I still have to see a clear need for having these
tools by default in all pages.
Comment 8 Andreas Nilsson 2007-05-21 18:36:52 UTC
Yes, centered sound good to me.
Can we reuse the current graphics for the bar?
I'll get started on the icons, as we still need those, right?
Comment 9 Quim Gil (reporter) nokia 2007-06-04 10:48:25 UTC
Reassigning to Niels.

Let's place the tools bar centered right under the primary navigation bar. It
would be good to keep the white space between the primary nav bar and the
slogan as it is, saving some vertical scroll and winning so default visibility
for the Planet component.
Comment 10 Quim Gil (reporter) nokia 2007-06-12 07:30:04 UTC
Can we have this fixed? In some cases the toolbar creates a second line (i.e.
seems to be the case in default Ubuntu + Firefox settings). The issue is solved
by changing the location.
Comment 11 Andreas Nilsson 2007-06-12 13:22:06 UTC
Created an attachment (id=469) [details]
mockup of the moved bar

Seems to work ok.
Comment 12 Niels Breet maemo.org 2007-06-13 09:38:16 UTC
(In reply to comment #10)
> Can we have this fixed? In some cases the toolbar creates a second line (i.e.
> seems to be the case in default Ubuntu + Firefox settings). The issue is solved
> by changing the location.
> 

Ok, will fix this tomorrow. I have to travel today, but will commit it when I'm
back.
Comment 13 Niels Breet maemo.org 2007-06-14 12:43:04 UTC
Committed this change to svn. Let's see if the replication picks it up..
Comment 14 Andreas Nilsson 2007-06-14 18:06:50 UTC
Created an attachment (id=473) [details]
eeek

hm, am I the only one getting this glitz?
Comment 15 Niels Breet maemo.org 2007-06-14 18:16:45 UTC
(In reply to comment #14)
> Created an attachment (id=473) [details] [details]
> eeek
> 
> hm, am I the only one getting this glitz?
> 

No, it is just that the static files _still_ aren't replicated from the test
server to the live one. That is a problem we have for a few months now. Ferenc
syncs them manually, when I ask him to.

I altered frontpage.css at the same time as the commit, but those changes
aren't on the live server yet. Mailed Ferenc about that an hour ago orso..
Comment 16 Quim Gil (reporter) nokia 2007-06-15 12:18:25 UTC
Now looks better but still not there:

- Text should be centered.
- Frame should extend only to wrap the text, now it extends to the whole body
space.
- background of "open source development..." looks back together with defalt
white background. Problem probably solved if image is tied to tools bar with no
white in between, and aligned totally to the left (with again no white space).
- Cosmetic thing, now the ">>" probably don't make much sense.
Comment 17 Niels Breet maemo.org 2007-06-15 18:16:34 UTC
(In reply to comment #16)
> Now looks better but still not there:
> 
> - Text should be centered.
> - Frame should extend only to wrap the text, now it extends to the whole body
> space.

Yeah.. I did it the way it is now, because automatically growing float and
centered is pretty hard to get right on all supported platforms. If you really
want that, I need to create that bar in a different manner. So it is possible,
but a lot more work. Please tell me what to do..

> - background of "open source development..." looks back together with defalt
> white background. Problem probably solved if image is tied to tools bar with no
> white in between, and aligned totally to the left (with again no white space).

I can change that easily.

> - Cosmetic thing, now the ">>" probably don't make much sense.
> 

Can also be removed easily.

Are there other things that need to be taken in account? Like icons etc? Are we
going to do that?
Comment 18 Quim Gil (reporter) nokia 2007-06-18 08:17:38 UTC
The current solution is not elegant and we have a quite elegant homepage now. I
think it's worth to invest the time in an elegant solution.

No icons planned at this point. I personally don't think they are needed.
Comment 19 Niels Breet maemo.org 2007-06-18 11:14:22 UTC
(In reply to comment #18)
> The current solution is not elegant and we have a quite elegant homepage now. I
> think it's worth to invest the time in an elegant solution.

Ok, I'm going to work that..

> No icons planned at this point. I personally don't think they are needed.
> 
Ok, no problem.
Comment 20 Niels Breet maemo.org 2007-07-17 13:40:49 UTC
Resolving this bug.
Comment 21 Jake Kunnari 2007-12-04 12:52:20 UTC
Closing RESOLVED and FIX bugs. If error/problem still occurs, please reopen bug
with proper comments.