Bug 1288

Summary: Editing the bugzilla guidelines (bug-writing.html)
Product: [Websites] maemo.org Website Reporter: Quim Gil <quim.gil>
Component: BugzillaAssignee: Andre Klapper <andre_klapper>
Status: RESOLVED FIXED QA Contact:
Severity: enhancement    
Priority: High CC: andre_klapper, karstenb
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: Linux   
URL: https://maemo.org/bugzilla/page.cgi?id=bug-writing.html
Attachments: updated / shortened / rewritten bug-writing.html
updated / shortened / rewritten bug-writing.html
revised version

Description Quim Gil (reporter) nokia 2007-05-05 12:35:11 UTC
I'd like to edit https://maemo.org/bugzilla/page.cgi?id=bug-writing.html

What are the steps to proceed?
Comment 1 Jake Kunnari 2007-05-22 14:54:26 UTC
Moved to correct Product and Component.
Comment 2 Andre Klapper maemo.org 2008-05-02 17:01:01 UTC
quim, can you attach/post your changes/plans here so they don't get lost/work
does not get duplicated?
Comment 3 Quim Gil (reporter) nokia 2008-07-19 15:33:35 UTC
(In reply to comment #2)
> quim, can you attach/post your changes/plans here so they don't get lost/work
> does not get duplicated?

I'm sure now you have better plans.  :)
Comment 5 Andre Klapper maemo.org 2008-07-22 17:32:51 UTC
Created an attachment (id=834) [details]
updated / shortened / rewritten bug-writing.html

I have shortened and maemo'fied the bug-writing.html site so it's less to read
and more useful.
After getting this published we will save time triaging bad reports by just
linking to this page.
Comment 6 Andre Klapper maemo.org 2008-07-22 17:33:30 UTC
Karsten: Can I get a review and/or commit?
Comment 7 Quim Gil (reporter) nokia 2008-07-23 12:24:27 UTC
Works for me. Thanks!
Comment 8 Andre Klapper maemo.org 2008-07-25 14:52:40 UTC
Created an attachment (id=840) [details]
updated / shortened / rewritten bug-writing.html

get rid of "herself" and change it to plural. good comment by GeneralAntilles.
;-)
Comment 9 Ryan Abel maemo.org 2008-07-25 15:14:21 UTC
Alright, few revisions, starting from the top:

> GOOD: ...

The GOOD bug report example needs a closing quotation mark.

> Product: In which product did you find the bug?
> You just specified this on the last page, so you can't edit it here.

Confusing and probably too context specific if somebody gets to this page from
somewhere other than that point in the submission process. Maybe more verbosity
would help.

> OS: On which Operating System (OS) did you find this bug? (e.g. Linux, Windows, Mac OS X.)
> If you know the bug happens on all OSs, choose 'All'. Otherwise, select the OS that you found the bug 
> on, or "other" if your OS isn't listed.

This should probably mention the recommended usage of "IT OS" in the OS field.
The rest pretty much only apply to stuff like the ITVC. . . .

> A useful summary might be "DSP kernel does not contain CLK functionality". "Software fails" or
>  "Cannot send mail" would be examples of a bad summary.

Confusion, appears as though "Software fails" and "Cannot send mail" are part
of the "useful" list. The "useful" example is probably a little heavy for the
kind of people that will be reading this page. Maybe try (not in love with the
useful examples, but you probably get the idea):0

     A useful summary might be "Modest crashes when fetching from Gmail over
IMAP" or "Center dpad press is treated as <enter> key, triggering form submit
instead of activating finger keyboard".
     A bad summary would be something like "Software fails" or "Cannot send
mail".

> REPRODUCIBILITY: Is this bug always reproducible (this means that you have tried two or three times),
> or only sometimes?

Per the discussion on the lists, this might be worth revising. 2-3
reproductions isn't really a large number.

> Good bug titles:
>
> "1.0 upgrade installation fails if Mozilla M18 package present" - Explains problem and the context.
> "RPM 4 installer crashes if launched on Red Hat 6.2 (RPM 3) system" - Explains what happens, and
> the context.

These are way too heavy and completely unrelated to Maemo. Need revision (too
early in the morning for me to be thinking up good bug summaries. Do it
yourself. :P).
Comment 10 Andre Klapper maemo.org 2008-07-25 16:33:06 UTC
Created an attachment (id=841) [details]
revised version

Thanks for the comments!
Comment 11 Karsten Br├Ąckelmann 2008-08-11 13:05:19 UTC
Merged the changes with the Bug Writing Guidelines template, with a few minor
corrections and a lot of Bugzilla-isms. This was one tedious work. And 'diff'
sometimes is rather useless...

Will be pushed to the live [% terms.Bugzilla %] soon.

Closing RESOLVED FIXED.
Comment 12 Karsten Br├Ąckelmann 2008-09-16 22:40:03 UTC
Spotted a bad phrase yesterday, in the Bug Writing Guidelines "good" example.
Corrected in SVN.

s/I /The browser /;  # crashed