Bug 1195

Summary: PAN Bluetooth Profile not supported
Product: [Maemo Official Platform] Connectivity Reporter: phi <fatbro>
Component: BluetoothAssignee: Quim Gil <quim.gil>
Status: RESOLVED WONTFIX QA Contact: bluetooth-bugs
Severity: enhancement    
Priority: High CC: 003bugzilla, bugzilla770, dan.buckler, mike, nitind, quim.gil, thoughtfix, Tim
Version: 1.1Keywords: enhancement-it2006, enhancement-it2007
Target Milestone: ---   
Hardware: All   
OS: All   

Description phi (reporter) 2007-04-02 18:24:46 UTC
Windows Mobile 2005 AKU3 and Windows Mobile 2006 phones only support the PAN
(Personal Area Network) Bluetooth Profile, not the DUN (Dial-Up Networking
Profile). The Internet Tablet can not easily network via bluetooth to connect to
the internet.  Please Fix.
Comment 1 Jake Kunnari 2007-04-03 10:16:47 UTC
Changed to Enhancement. Quim Gil added to cc-field.
Comment 2 phi (reporter) 2007-05-08 17:57:28 UTC
if this doesn't get addressed in IT2006, please add it to IT2007 and the hacker
editiong for the 770
Comment 3 David Campbell 2007-05-09 14:49:11 UTC
*** Bug 1346 has been marked as a duplicate of this bug. ***
Comment 4 David 2007-06-13 15:27:45 UTC
Becoming very urgent !
Just tell us if you plan to fix it (end when)
Comment 5 Darren Long 2007-06-13 23:17:07 UTC
Urgent indeed.  Even Apple have got PAN working in Mac OS X 10.4.9.  This works
reliably with my Sony Ericsson K800i and the UK '3' 3G service, the combination
of which doesn't work at all with PPP on my n800.

Please, please, please get this implemented.  PPP is so 20th Century!
Comment 6 Daniel Gentleman 2007-06-14 22:33:34 UTC
Fanoush in InternetTabletTalk forums posted a workaround script for this,
described here:
http://www.internettablettalk.com/forums/showthread.php?t=6794
This is NOT a real solution as installation, connection, and disconnection are
still tricky. I can create an installer script, but would prefer to enlist
maemo developers in releasing a .deb that enables this on normal phone
connections.
Comment 7 Quim Gil nokia 2007-06-15 12:27:24 UTC
Please, have a look to what "blocker" means before assigning this flag to a bug
report. This is an enhancement request, no matter how much you need it.

I will try to find out what are the plans.
Comment 8 Quim Gil nokia 2007-06-15 13:12:24 UTC
So. There is PAN functionality in the device but not officially supported and
therefore no GUI for end users. Having it officially supported would imply a
lot of paperwork and there are no current plans to go through this.

Oportunity for community contribution? Come up with a page describing the
feature and the intent and I will add it to the
http://maemo.org/intro/roadmap.html with the "(Community)" tag.

Just for the record, there is this page in the community documentation wiki:
http://maemo.org/community/wiki/HOWTO-BluetoothNetworking
Comment 9 Frantisek Dufka maemo.org 2007-06-15 13:38:54 UTC
(In reply to comment #8)

> Oportunity for community contribution? Come up with a page describing the
> feature and the intent and I will add it to the
> http://maemo.org/intro/roadmap.html with the "(Community)" tag.

I have already requested this few times, check point 2 in
http://www.gossamer-threads.com/lists/maemo/developers/15410#15410
So far it was always ignored (i.e. no reply from you in early 2007 or Kalle in
early 2006).

Even if we can make PAN working, there is currently no way (AFAIK) how to hook
it into the UI as the connection types are not extensible. Please correct me if
I am wrong on this and I can in fact implement custom connection type for
connection manager.
Comment 10 Frantisek Dufka maemo.org 2007-06-15 14:51:31 UTC
Well in fact it was not ignored but is included in community wishlist and
called "Simultaneous WLAN+BT connections - VPN" in the roadmap. Maybe it should
also include something more generic like "Custom internet connection types" or
"Extensible Internet Connection API"

And personally I'd like to see it not in Wishlist but in Roadmap :-) Maybe this
PAN issue was not considered important since it was mainly used for connections
with other computers (like ad-hoc wifi) but since now it is also used as
preferred interface in mobile phones for internet connectivity it should be
supported as soon as possible, check related info here
http://blogs.msdn.com/windowsmobile/archive/2007/04/17/why-did-we-remove-bluetooth-dun.aspx
In future there may be more phones supporting only PAN and not DUN so unless
you implement it you should be more careful in marketing materials when you say
something like 'you can use your phone to connect to internet'.
Comment 11 Neil MacLeod maemo.org 2007-06-15 15:20:10 UTC
I really don't understand how the argument "there is a lot of paperwork" can be
used as justification for not supporting your users.

The fact is that when you read that MSDN blog article it becomes clear that
even if/when DUN is added back as a default build option by Microsoft in future
versions of Windows Mobile, there is little incentive for the Carriers to
include DUN in their phones as DUN appears to result in an increased support
overhead compared to ICS/PAN.

DUN support is thus not guaranteed in future, and is currently not an option
for any WM5 AKU3 users today meaning PAN support on Internet Tablets is an
imperative rather than a wishlist. The rot has already set in as far as DUN on
WM is concerned and DUN will now be in decline going forward.

Of course, this is a problem caused by Microsoft and it (currently) affects
only non-Nokia phones running Windows Mobile but come on... is that how this is
going to play out? Microsofts reasons for preferring PAN over DUN seem
reasonable (though dropping DUN entirely was rash) and the Carriers appear to
prefer PAN/ICS to DUN so why not go with the flow and add official ITOS support
for PAN sooner rather than later? Without PAN connectivity support the Internet
Tablet OS range will be incompatible with all current and probably most future
Windows Mobile phones and that isn't something I want to see.

Hopefully the community can come up with something but whatever is produced
must be as easy to use as DUN, and also be integrated into the Phone Wizard -
Windows Mobile users don't want to have to use xterm just to get their phone
connected! Maybe the community can come up with something (there are already
interesting scripts out there) but I'd have thought official support would be
the obvious and logical thing to do, irrespective of the amount of paperwork.
Comment 12 Daniel Gentleman 2007-06-15 21:35:58 UTC
I created a proposal as Quim Gil requested and am opening it up to user notes
and contributions. Please reply to this thread:
http://www.internettablettalk.com/forums/showpost.php?p=52440&postcount=9
Comment 13 Quim Gil nokia 2007-06-17 10:15:46 UTC
Thanks Daniel, you are on the right track. I recommend you to use
http://maemo.org/community/wiki/ and crate your page there, so it is easier for
you and other to keep an updated version, add relevant links and so on. 

I will create a link to this page from the Wishlist section in roadmap and I
will dig again in our organization to see if your well formulated request and
the rcent nws around PAN/DUN bring any change to this WONTFIX. At least we
should provide better arguments now that you are articulating a better
proposal.
Comment 14 Daniel Gentleman 2007-06-18 01:34:10 UTC
Created
https://maemo.org/community/wiki/bluetooth_pan_proposal.html
Linked from
https://maemo.org/community/wiki/improvementideas.html

Hope this gets sent back upstream. Thanks for the directions, Quim Gil.
Comment 15 Quim Gil nokia 2007-06-18 08:14:23 UTC
Yes, I will make sure that whoever has a vote on this decision knows about this
proposal. It is now linked from the roadmap (Wishlist - Platform):
http://maemo.org/intro/roadmap.html

I will come back to this report as soon as I have any news. Thanks again for
your perseverance.
Comment 16 Jake Kunnari 2007-09-05 11:22:45 UTC
*** Bug 1932 has been marked as a duplicate of this bug. ***
Comment 17 Tim Riker 2007-11-21 00:49:47 UTC
I'll also put my vote in here. It seems Nokia is looking for the community to
fix this issue. To my knowledge, the code that needs to change is not available
to the community. How then will the community offer up a fix? Either:

Nokia should release ALL the code that needs to change

or

Nokia should provide the feature themselves.

Surely you are not expecting the community to completely replace the cellular
connectivity UI with another that has this one minor feature added?

This is a highly annoying feature. I pickup one of the latest phones (a Sprint
Mogul) that has the phone features I need, and the N800 won't even talk to it.
Now my N800 sits idle at home as I can't get online if I carry it around with
me anyhow.

The documention on getting this to work is flakey at best. As it does not
itegrate into the UI, getting a PAN connection going it painful. As the UI
knows nothing about the PAN connection, keeping that connection up is nearly
impossible. The pain involved, makes the device useless. At home collecting
dust.

And so we leave it. "RESOLVED WONTFIX". nice. guess it's time to look for
another device.
Comment 18 Jake Kunnari 2008-01-25 11:17:23 UTC
*** Bug 2832 has been marked as a duplicate of this bug. ***
Comment 19 Leif Ryge 2008-03-01 02:12:13 UTC
Martin Grimme has released a package which provides [a GUI for] PAN on ITOS:
https://garage.maemo.org/projects/maemo-pan