Bug 11145

Summary: No tones are played
Product: [Extras] ringtoned Reporter: Jörgen Scheibengruber <jorgen.scheibengruber>
Component: GeneralAssignee: Marco Barisione <marco>
Status: RESOLVED FIXED QA Contact: general
Severity: critical    
Priority: Unspecified CC: jorgen.scheibengruber, marco, radusebastian_capitanu, Saubha
Version: unspecified   
Target Milestone: ---   
Hardware: All   
OS: Maemo   
Attachments: Log for default ringtone (custom mp3 though)
Log for per-contact ringtone (custom mp3)
Log for default ringtone, now using Nokia Tune
ringtoned
libringtoned
per-contact-ringtones

Description Jörgen Scheibengruber (reporter) nokia 2010-08-16 22:57:05 UTC
SOFTWARE VERSION: 0.2.1

EXACT STEPS LEADING TO PROBLEM: 
1. Upgraded from 0.2.0 to 0.2.1 
2. Call yourself from several phones

EXPECTED OUTCOME: Default ringtone or custom ringtone playing

ACTUAL OUTCOME: Silence

REPRODUCIBILITY: For me, always

EXTRA SOFTWARE INSTALLED: some, but none that should be relevant in this
context
Comment 1 Jörgen Scheibengruber (reporter) nokia 2010-08-16 23:11:28 UTC
Created an attachment (id=3033) [details]
Log for default ringtone (custom mp3 though)
Comment 2 Jörgen Scheibengruber (reporter) nokia 2010-08-16 23:14:14 UTC
Created an attachment (id=3034) [details]
Log for per-contact ringtone (custom mp3)
Comment 3 Jörgen Scheibengruber (reporter) nokia 2010-08-16 23:21:00 UTC
Created an attachment (id=3035) [details]
Log for default ringtone, now using Nokia Tune

Note: this one (Nokia Tune) works, and I can hear it.
Comment 4 Jörgen Scheibengruber (reporter) nokia 2010-08-16 23:26:11 UTC
> Actually playing /home/user/.local/share/sounds/ringtoned/cdcad07ff0ec71339c85cff1dfbffa26.wav

I've copied it this to ~/MyDocs, so that the music-player sees it; it plays
fine there.
Comment 5 Marco Barisione 2010-08-17 02:15:54 UTC
The logs look fine, but I was so smart not to print any debugging message if
playing a file fails...

I uploaded a 0.2.2 version with more debugging info and a new command for
ringtoned-ctl to remove the cache files.
Can you please try:
ringtonedctl stop
ringtonedctl clean-cache
ringtonedctl startwait > ringtoned.log 2>&1

Just the case when it fails should be enough for now.
Thanks.
Comment 6 Marco Barisione 2010-08-17 02:32:57 UTC
Hm, maybe you could also try to send me the mp3 file that fails via email as I
cannot reproduce.
I'm so tempted to go back to GStreamer using only wavparse...
Comment 7 Marco Barisione 2010-08-17 11:41:23 UTC
*** Bug 11146 has been marked as a duplicate of this bug. ***
Comment 8 Marco Barisione 2010-08-17 14:32:23 UTC
Can you please test with the attached packages? They use GStreamer again, but
not using playbin2.
Comment 9 Marco Barisione 2010-08-17 14:33:03 UTC
Created an attachment (id=3037) [details]
ringtoned
Comment 10 Marco Barisione 2010-08-17 14:33:21 UTC
Created an attachment (id=3038) [details]
libringtoned
Comment 11 Marco Barisione 2010-08-17 14:33:37 UTC
Created an attachment (id=3039) [details]
per-contact-ringtones
Comment 12 Jörgen Scheibengruber (reporter) nokia 2010-08-17 17:39:57 UTC
Tried those packages and it works *woohoo* :-)
Comment 13 Marco Barisione 2010-08-17 20:52:23 UTC
This should be hopefully fixed in 0.2.3.
Comment 14 Radu Capitanu 2010-08-17 21:03:36 UTC
(In reply to comment #13)
> This should be hopefully fixed in 0.2.3.
> 

wher can I find 0.2.3?
Comment 15 Marco Barisione 2010-08-17 21:07:24 UTC
I uploaded it to extras-devel, so it should be there shortly. It's also in my
private repo.
Comment 16 Saubha 2010-08-19 04:17:36 UTC
It still isn't working for me, as I commented on your blog.
Comment 17 Marco Barisione 2010-08-19 19:23:58 UTC
Can you please open a terminal and type this:
ringtonedctl stop
ringtonedctl -d startwait > ~/MyDocs/ringtoned.log 2>&1

Then attach here the ringtoned.log file that is in your documents directory.