Bug 11095

Summary: Answer/reject buttons move when receiving a call
Product: [Maemo Official Applications] Chat & Call & SMS Reporter: Matti Viljanen <matti.viljanen>
Component: Call Application UIAssignee: rtcomm <rtcomm>
Status: RESOLVED DUPLICATE QA Contact: call-ui-bugs
Severity: major    
Priority: Unspecified CC: andre_klapper
Version: 5.0:(10.2010.19-1)   
Target Milestone: ---   
Hardware: ARM   
OS: Maemo   

Description Matti Viljanen (reporter) 2010-08-08 17:54:27 UTC
SOFTWARE VERSION:
10.2010.19-1

EXACT STEPS LEADING TO PROBLEM: 
1. Set your phone to portrait only mode
2. Close the keyboard
3. Open some landscape-only application, e.g. read SMS
4. Lock the keys (may not be needed)
5. Receive a call
6. See the screen flip

EXPECTED OUTCOME:
7. After the flip the answer and reject buttons are located on their proper
locations
8. Answering the call can be done immediately

ACTUAL OUTCOME:
7. After the flip the buttons are briefly in correct positions, then they get
repositioned (either by false landscape mode rendered in portrait mode, or) so
that the buttons get "lifted up by one button".
8. Answering the call with poorly-timed screen tap may actually click the red
button, ending the call, or the SMS button, bringing the SMS app up and leaving
the phone app still silently ringing on the background.
9. Call your friend back blaming the phone...

WORKAROUND
7. After the flip wait some 2..3 seconds
8. Watch the buttons "jump around"
9. When they stop, answer the call


REPRODUCIBILITY:
About 6/10. The amount of opened applications does not seem to affect the rate.

EXTRA SOFTWARE INSTALLED:
3G/2G mode applet, Angry Birds, bash3, Brain Party, Calendar home widget,
Carbon theme, Conky, cpumem-applet, Docs To Go Viewer, DrNokSnes, Droid Fonts,
Dropbear SSH client, eCoach, Facebook apps, Firefox, Flashlight, FM Radio
Player, fMMS, GPSJinni, Headphone Daemon, htop, Hydrocarbon theme, iNes,
instinctiv, iStyle Light theme, Joikuspot, LED pattern editor, mad-developer,
Melody theme, Morpho QuickPanorama Pro, MPlayer cli, MSN protocol plugin for
Conv. and Cont., Nameday applet, OMWeather + database + Shiny icons, OpenNTPD,
OpenSSH server, Opera Mobile, Password Safe, rootsh, Simple Brightness Applet,
SBP Brain Evolution, Zen Bound

OTHER COMMENTS:
I use Carbon or Hydrocarbon theme usually. This might have something to do with
it, but I don't have time right now to test it.

Also, I have only one desktop view active. It has the following widgets: Home
Calendar Widget, OMWeather, Nameday Applet and icons: Phone, PW safe, pics, FM
radio, media player, xterm, Firefox, Web, Opera, Maps

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/533.4
(KHTML, like Gecko) Chrome/5.0.375.99 Safari/533.4
Comment 1 Andre Klapper maemo.org 2010-08-09 11:41:45 UTC
Hi Matti, thanks for reporting this!
This particular issue has already been reported in our bug tracking system, but
please feel free to report any further bugs you find.

*** This bug has been marked as a duplicate of bug 10613 ***