Bug 1050

Summary: "Connect automatically" should be connection specific
Product: [Maemo Official Platform] Connectivity Reporter: Neil MacLeod <bugzilla770>
Component: ICDAssignee: unassigned <nobody>
Status: RESOLVED WONTFIX QA Contact: icd-bugs
Severity: enhancement    
Priority: Medium CC: alexatkin, andre_klapper, fredrik, laurent, mag, quim.gil, rabelg5
Version: 5.0/(2.2009.51-1)   
Target Milestone: Harmattan   
Hardware: All   
OS: All   

Description Neil MacLeod (reporter) maemo.org 2007-02-13 02:32:36 UTC
Currently one can specify that WLAN, Phone or both connection types will auto
connect.

This is quite inflexible as there are some WLANs to which I want to auto connect
to, and there are also some that I do NOT want to auto connect.

I propose that the "Auto Connect" status is made connection specific, or at
least add a "Do not auto connect" option to each individual connection setting
which will override the global "auto connect" setting. 

For example, I would want to auto connect to my "home" WLAN but I would not want
to auto connect to any WLAN in my "work" environment. I would connect to a WLAN
in a "work" environment by performing a manual scan, and selecting from the
available WLANs.
Comment 1 oouc 2007-08-27 01:18:32 UTC
phone4u shop employee wanted to see if he could connect my 
N800 to the weak btopenzone signal.  So he turned on 
connect automatically to btopenzone.  This is expensive 
because it now connects to this paid service every time I 
turn the N800 on.  Sometimes it connects then loses the 
connection and British Telecom is so nice they love to 
charge 15 minutes more of connect time because I did not 
have a chance to log off before the N800 or BT loses the 
connection.

1st workaround was
Under Connection Manager -> Tools -> Connectivity Setting there are two
settings:

Connect automatically: WLAN connections
Search interval: Never
but now I cannot connect automatically to any of my free services.

2nd work around I will try is to delete BtOpenzone and then recreate it 
without any auto connection.  This should work but it is not as good 
a solution that Neil MacLeod <bugzilla770@nmacleod.com>, this bug 
reporter, initially suggested.  Priority levels including 0 for never 
connect automatically and higher numbers for the most desirable auto 
connections are the best way to do it.
Comment 2 Andre Klapper maemo.org 2008-10-11 03:01:55 UTC
*** Bug 3599 has been marked as a duplicate of this bug. ***
Comment 3 Quim Gil nokia 2008-12-28 20:17:36 UTC
Isn't this a worksforme? Autoconnections hazppen only among saved
connections.If you want certain network to stay out of autoconnection then
don't save it.
Comment 4 Ryan Abel maemo.org 2008-12-28 20:55:07 UTC
(In reply to comment #3)
> Isn't this a worksforme? Autoconnections hazppen only among saved
> connections.If you want certain network to stay out of autoconnection then
> don't save it.
> 

This gets quite obnoxious after a short while, as if you only want to
auto-connect to one or two WiFi networks, you'll have to tap through several
more dialogs (no, I do not want to save) for networks you may connect to
frequently, but do not wish to auto-connect to.

Reopening, as the functionality provided by saved connections and auto-connect
is insufficient. We need some way to differentiate between saved connections we
want to auto-connect to and ones we don't (or some other revision of the
saved/auto-connection system).
Comment 5 Neil MacLeod (reporter) maemo.org 2008-12-28 23:49:52 UTC
Quim - I agree entirely with Ryan and I don't think you're understanding the
issue here, as not saving a connection to avoid it auto-connecting is simply
not an acceptable solution, mainly because (as Ryan points out) to re-establish
the connection you then have to re-enter all the security details and tap
through several dialogs (remembering not to press "Save Connection" at the
end!)

The use-case here is, for example, a restricted works connection that I may
connect to frequently for specific work-related purposes but it's not a
connection I want to connect to automatically and all the time for general
internet access which the N8x0 is prone to do unless I shut off the WiFi by
taking it offline, and then I need to remember to re-enable the WiFi when I
*do* want it to connect automatically, for example when I get home.

Another use-case might be a paid-for WiFi connection (eg. a cafe) which I use
from time to time. If I'm in the vicinity of the paid-for connection I don't
want my N8x0 connecting automatically and running up a bill without my
knowledge, but then again I do want the convenience of a saved connection so
that I can quickly log on when I need internet access.

All this enhancement requires is a simple boolean flag against each connection
(WiFi, Bluetooth, WiMax, HSPA, whatever) and the centralised logic (it is
centralised, right?) that determines if a connection can be automatically
establised on-demand simply needs to respect this flag... job done.

Feel free to propose an alternative solution, however the above covers this
requirement as I see it. There are a few outstanding bugs relating to improving
connectivity (bug 1231, bug 1043/bug 402, possibly more) and it would be good
if they could all get some attention for Freemantle as Connectivity is a bit of
a hodge-podge as it stands, with tiresome and unecessary delays and a general
lack of refinement.
Comment 6 Neil MacLeod (reporter) maemo.org 2008-12-28 23:53:19 UTC
Whoops, bug 1232 not bug 1231! :)
Comment 7 Quim Gil nokia 2008-12-29 11:48:52 UTC
Note to self: one shouldn't try to resolve bugs on a Sunday afternoon with
children playing around.  ;)
Comment 8 Neil MacLeod (reporter) maemo.org 2008-12-29 16:49:39 UTC
(In reply to comment #7)
> Note to self: one shouldn't try to resolve bugs on a Sunday afternoon with
> children playing around.  ;)
> 

Don't be so hard on yourself - any input from Maemo people is most welcome
round here, otherwise we'd be talking to ourselves! ;-) And to be posting on a
Sunday... that's beyond the call of duty!
Comment 9 Fredrik Wendt 2010-01-07 12:12:08 UTC
My use case: 
Please auto connect to my home-wlan,
but don't auto connect the work-wlan (since that network requires browser login
and the N900 doesn't support that, there's even no workaround (bug 7678)),
and don't auto connect to the TeliaSonera wifi hot-spots (since that requires
browser login ...),
and don't auto connect to the University wifi hot-spots (since that requires
browser login ...),
and don't auto connect to the café's wifi hot-spot (sinc taht requires browser
login ...).

I use the work-wlan on a daily basis, but I don't want to loose all connections
just because I come close to work.
I use University and TeliaSonera (telephone network operator) networks an a
weekly basis. One of these I could auto-connect since I've got a static code
and the login page doesn't include any CAPTCHA-boxes. The other I need to send
an SMS to acquire a login code (valid for 24 hours).
I rarely use the cafe hot-spot, but it's on the way to/from work and it's
recognized.

So, yes, I always want to connect when I get home. Any other WLANs require
browser login and I guess most larger cities looks like this nowadays.
Comment 10 Quim Gil nokia 2010-01-22 10:34:52 UTC
There is progress for this feature in the Harmattan plans: users will be able
to define connections that will connect automatically.

Setting target milestone.
Comment 11 Alex Atkin UK 2010-05-17 13:33:17 UTC
(In reply to comment #10)
> There is progress for this feature in the Harmattan plans: users will be able
> to define connections that will connect automatically.
> 
> Setting target milestone.
> 

So its taken (or will have) over three years to implement this simple
enhancement?  No wonder people get so upset.

Had this been a desktop distro there would have been an unofficial patch in
weeks, been implemented as standard in 6-12 months max.

I didn't understand why people were so upset with Fremantle but now looking at
things like this I totally understand.  It was/is missing basic functionality
people were asking for nearly two years prior.
Comment 12 Andre Klapper maemo.org 2012-03-21 18:06:57 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia, hence resetting the ASSIGNED
status to NEW/UNCONFIRMED as nobody is working on this.

Note that very likely any feature requests for Maemo5 will not receive fixes
(WONTFIX) - I might mass-set this status in the future. There is a very small
chance for issues in open source components that contributed patches could be
included in the Maemo 5 CSSU Community updates - see http://wiki.maemo.org/CSSU
for more information.


For completeness (as Harmattan is mentioned in some reports), MeeGo 1.2
Harmattan used for the N9 and N950 is handled in
http://harmattan-bugs.nokia.com/ which has recently been closed for new bug
report entry [1].

[1]
http://www.developer.nokia.com/Community/Blogs/blog/n9-developer/2012/03/08/harmattan-bugzilla-closed-for-new-bugs
Comment 13 Andre Klapper maemo.org 2012-03-24 11:39:13 UTC
The Maemo 5 User Interface and Maemo 5 platform components (e.g. libraries)
used for the N900 are considered stable by Nokia and it seems that there are no
plans for official updates currently, hence nobody plans to work on this
enhancement/wishlist request. 
(And in case you feel like discussing this situation: Nokia Customer Care or
http://talk.maemo.org would be the place to do so as you will not reach Nokia
officials in this community bugtracker - though all of this is really no news.)

Reflecting this status by setting RESOLVED WONTFIX for this
enhancement/wishlist request (see
https://bugs.maemo.org/page.cgi?id=fields.html#status for status explanations).

There is a small chance for issues in those Maemo components that are open
source: Contributed patches could be included and made available in the Maemo 5
Community CSSU updates. 
The Maemo CSSU project is run by a small team of volunteers; see
http://wiki.maemo.org/CSSU for more information.
So in case that you can provide a patch that fixes the reported problem, please
feel encouraged to file a request under
https://bugs.maemo.org/enter_bug.cgi?product=Maemo%205%20Community%20SSU .
Please note: The Maemo CSSU project is not related in any way to Nokia.


( Tag for mass-deleting bugmail: [cleanup20120324] )