Bug 10442 (int-172046)

Summary: Flash Video Fullscreen mode only partially fills screen on some sites
Product: [Maemo Official Applications] Browser Reporter: jessi3k3
Component: Plug-ins: FlashAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: adobe-flash-bugs
Severity: normal    
Priority: Unspecified CC: andre_klapper, djpro1, stefan-johansson78
Version: 5.0:(10.2010.19-1)   
Target Milestone: 5.0/(20.2010.36-2)   
Hardware: All   
OS: Maemo   
URL: http://fora.tv/2010/05/22/Adam_Savage_Presents_Problem_Solving_How_I_Do_It#Adam_Savage_Banned_MythBusters_Episode_on_Cannibal_Mouse
Attachments: Screenshot of issue. Video width seems to be 480 pixels

Description jessi3k3 (reporter) 2010-05-31 06:40:43 UTC
(Settings > General > About product)

(Explain in detail what you do (e.g. tap on OK) and what you see (e.g. message
Connection Failed appears))
1. Open MicroB
2. Visit a website with flash video (ex: www.fora.tv . Youtube works ok)
3. Open any video (ex:
4. Let it buffer a bit then click the fullscreen button

Video is resized to fit screen and fills the screen

Video only takes up around 1/4 of screen. The width of the video always seems
to be 480 pixels.

(always, less than 1/10, 5/10, 9/10)
10/10 (in that site)


Since the width is always 480 pixels, can it be that it "thinks" that it is in
portrait mode therefore it resizes the video to only fill 480 pixel width?
I have auto-rotation disabled.

Videos would properly fill the screen using PR 1.1

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:
Gecko/20100401 Firefox/3.6.3
Comment 1 jessi3k3 (reporter) 2010-05-31 06:41:37 UTC
Created an attachment (id=2786) [details]
Screenshot of issue. Video width seems to be 480 pixels
Comment 2 Andre Klapper maemo.org 2010-06-02 14:56:19 UTC
Hi Jesus, thanks for reporting this! Confirming.
Comment 3 stefan 2010-06-03 02:41:42 UTC
thanks for filling bugrapport confirming this bug
Comment 4 gentius 2010-06-24 03:05:08 UTC
confirming  same issue on my n900 after 1.2 update...
Flashed again firmware 1.2 , fiasco image , emmc vanilla still  it happens

I remember long time ago i  had same problem on my ubuntu 8.
It had something to do with compiz configuration which disabling  it solved the
issue..... i dont know  about this one...

guys help please.......................
Comment 5 Andre Klapper maemo.org 2010-06-24 09:27:57 UTC
(In reply to comment #4)
> I remember long time ago i  had same problem on my ubuntu 8.

This is definitely unrelated. A fix is currently being tested internally.

> guys help please.......................

Patience. Flash is closed-source anyway so there's nothing you can do.
Comment 6 Andre Klapper maemo.org 2010-06-29 12:58:25 UTC
This has been fixed in package
which is part of the internal build version
(Note: 2010 is the year, and the number after is the week.)

A future public update released with the year/week later than this internal
build version will include the fix. (This is not always already the next public
Please verify that this new version fixes the bug by marking this bug report as
VERIFIED after the public update has been released and if you have some time.

To answer popular followup questions:
 * Nokia does not announce release dates of public updates in advance.
 * There is currently no access to these internal, non-public build versions.
   A Brainstorm proposal to change this exists at
Comment 7 Andre Klapper maemo.org 2010-10-25 17:13:56 UTC
The problem reported here should be fixed in the update that was released today
for public: The Maemo5 update version 20.2010.36-2 (also called "PR1.3"
sometimes). Please leave a comment if the problem is not fixed for you in this
update version.