Bug 10101 (int-141557)

Summary: browser: incorrect display then internal error (double access to the same buffer)
Product: [Maemo Official Applications] Browser Reporter: Vincent Lefevre <vincent-maemo>
Component: MicroB engineAssignee: unassigned <nobody>
Status: RESOLVED FIXED QA Contact: microb-bugs
Severity: major    
Priority: Unspecified CC: andre_klapper
Version: 5.0/(3.2010.02-8)Keywords: crash
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   
URL: http://www.lyonpoche.com/cinema/recherche-horaire/rhone-alpes/ames-en-stock-24147/resultats.html

Description Vincent Lefevre (reporter) 2010-05-04 22:15:51 UTC
SOFTWARE VERSION:
3.2010.02-8.002

EXACT STEPS LEADING TO PROBLEM: 
1. I don't know how to reproduce, but the display on the above URL was
incorrect and I was trying to scroll.

EXPECTED OUTCOME:

ACTUAL OUTCOME:
The browser crashed with the message:
Internal error. Application Web closed.

REPRODUCIBILITY:
once

OTHER COMMENTS:
I can provide the core dump if need be.
In /var/log/syslog:
May  4 20:32:02 Nokia-N900-02-8 browserd[4993]: SET_ACTIVE:0x4430c0, 1->0,
is_layout_active:1, ChangeSusp:TRUE
May  4 20:32:02 Nokia-N900-02-8 browser[1534]: >>>Bad thing, double access to
the same buffer!!!!
May  4 20:32:08 Nokia-N900-02-8 browserd[4993]: SET_ACTIVE:0x4430c0, 0->1,
is_layout_active:0, ChangeSusp:TRUE
May  4 20:32:09 Nokia-N900-02-8 browser[1534]: GLIB WARNING ** default -
Message sending from "ui" to socket "eal" failed, len:-1
May  4 20:32:09 Nokia-N900-02-8 browser[1534]: GLIB WARNING ** default -
Message sending from "ui" to socket "eal" failed, len:-1
May  4 20:32:09 Nokia-N900-02-8 browserd[4993]: SET_ACTIVE:0x4430c0, 1->0,
is_layout_active:1, ChangeSusp:TRUE
May  4 20:32:09 Nokia-N900-02-8 browser[1534]: >>>Bad thing, double access to
the same buffer!!!!
May  4 20:32:11 Nokia-N900-02-8 browserd[4993]: SET_ACTIVE:0x4430c0, 0->1,
is_layout_active:0, ChangeSusp:TRUE
May  4 20:32:12 Nokia-N900-02-8 browserd[4993]: SET_ACTIVE:0x4430c0, 1->0,
is_layout_active:1, ChangeSusp:TRUE
May  4 20:32:12 Nokia-N900-02-8 browser[1534]: GLIB WARNING ** default -
Message sending from "ui" to socket "eal" failed, len:-1
May  4 20:32:12 Nokia-N900-02-8 browser[1534]: GLIB WARNING ** default -
Message sending from "ui" to socket "eal" failed, len:-1
May  4 20:32:12 Nokia-N900-02-8 browserd[4993]: SET_ACTIVE:0x4430c0, 0->1,
is_layout_active:0, ChangeSusp:TRUE
May  4 20:32:13 Nokia-N900-02-8 browser[1534]: GLIB WARNING ** default -
Message sending from "ui" to socket "eal" failed, len:-1
May  4 20:32:13 Nokia-N900-02-8 last message repeated 11 times
May  4 20:32:19 Nokia-N900-02-8 browserd[4993]: GLIB WARNING ** default -
Client disconnected, KILL self
May  4 20:32:19 Nokia-N900-02-8 maemo-launcher[948]: child (pid=1534)
terminated due to signal=11 
May  4 20:32:19 Nokia-N900-02-8 maemo-launcher[948]: no child 5632 found in the
kindergarten. 
May  4 20:32:19 Nokia-N900-02-8 maemo-launcher[948]: child (pid=5632)
terminated due to exit()=0 
May  4 20:32:19 Nokia-N900-02-8 crash_reporter_daemon:
[creporter_get_rcore_fileinfo]: File:
/home/user/MyDocs/core-dumps/browser-BC9A-11-1534.rcore.lzo size 1992698 
May  4 20:32:19 Nokia-N900-02-8 crash_reporter_daemon: new dups_count
entry:name=browser sig=11 low=1893063 up=2092332
Comment 1 Andre Klapper maemo.org 2010-05-05 03:38:22 UTC
Do you have Crsah Reporter installed?
Comment 2 Vincent Lefevre (reporter) 2010-05-05 10:48:04 UTC
Yes, I have Crash Reporter installed, but it wasn't configured to send crash
reports. This is now done, and the report has been sent.
Comment 3 Andre Klapper maemo.org 2010-05-06 15:27:12 UTC
This has been fixed for the next public update (PR1.2).