Bug 10041

Summary: Calender and Clock crash in Arabic localizition
Product: [Maemo Official Platform] Desktop platform Reporter: Adib <shami585>
Component: generalAssignee: unassigned <nobody>
Status: VERIFIED FIXED QA Contact: HAF QA mailing list <desktop-platform-general-bugs>
Severity: major    
Priority: Unspecified CC: andre_klapper, mohammad7410
Version: 5.0/(3.2010.02-8)Keywords: crash, moreinfo
Target Milestone: 5.0/(10.2010.19-1)   
Hardware: N900   
OS: Maemo   

Description Adib (reporter) 2010-04-26 23:29:44 UTC
SOFTWARE VERSION:
pr 1.1.1

EXACT STEPS LEADING TO PROBLEM: 
we make arabic translation for the UI .. and we have some problems..
this the package
http://maemo.org/packages/view/arabic-l10n/

1. when open the calender and try to add task it crashed..
2. when open the clock and try to edit the clock also it crashed..
3. (LOW Priority) the name of language appear as the code .. ar_SA and not
Arabic(Saudi) and this for all other arabic language codes...  


REPRODUCIBILITY:
(always, less than 1/10, 5/10, 9/10)

EXTRA SOFTWARE INSTALLED:

OTHER COMMENTS:

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US)
AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1045 Safari/532.5
Comment 1 Andre Klapper maemo.org 2010-04-27 13:02:47 UTC
Hi,
please file only one issue per report and please don't use "UI Specification"
if you don't know the UI Specification. :)

(In reply to comment #0)
> 1. when open the calender and try to add task it crashed..
> 2. when open the clock and try to edit the clock also it crashed..

Can you please install Crash Reporter from the SDK Tools repository in order to
send coredumps directly to Nokia?
See http://wiki.maemo.org/Extras-testing#Tools_for_testers for a how-to.
If you are offered to add a comment for sending the coredump file, please
mention this bug number (like "see bugs.maemo.org bug number xxxx").
Also, a filename will be displayed after uploading the coredump. Please add the
name of that file here in the bug report.


> 3. (LOW Priority) the name of language appear as the code .. ar_SA and not
> Arabic(Saudi) and this for all other arabic language codes...  

That is bug 8997 and will not be fixed for Maemo5. Aiming for Maemo6.
Please don't add "We need this too" comments to that report, just silently
"Vote for this bug" instead.
Comment 2 Mohammad Abu-Garbeyyeh 2010-04-28 01:45:20 UTC
The users who created the translations know about the bug.

Right now I'm not sure who even made the translations, you say you made them,
yet you were never mentioned when I packaged it.
Anyways, this isn't a Maemo bug, but rather a bug in the user-made
localization.
The name (ar_SA) is also a known bug in the translations, again I never took
part in the translation but it's a bug in the .po files.

I'll leave the decision of what to do with this bug to Andre.
Comment 3 Adib (reporter) 2010-05-03 00:15:50 UTC
Hi..

> please file only one issue per report and please don't use "UI Specification"
> if you don't know the UI Specification. :)

Sorry for that .. :)

> Can you please install Crash Reporter from the SDK Tools repository in order 
> to send coredumps directly to Nokia?

I tried to install it but it is not installed.. some packages are missing..
But there is someone who test it on the LEAKED new version and said that it
works...




(In reply to comment #2)
> The users who created the translations know about the bug.
> 
> Right now I'm not sure who even made the translations, you say you made them,
> yet you were never mentioned when I packaged it.
> Anyways, this isn't a Maemo bug, but rather a bug in the user-made
> localization.
> The name (ar_SA) is also a known bug in the translations, again I never took
> part in the translation but it's a bug in the .po files.
> 
> I'll leave the decision of what to do with this bug to Andre.
> 

For the translation i started it but the one who give you the files complete
the translation and made the most of works..
For this bug it is not from .po files i tried the english one with ar_SA and it
crashed also... so the problem is in the localizition sitting..
I think there is conflict between region sitting and the language one...
Comment 4 Mohammad Abu-Garbeyyeh 2010-05-03 07:51:39 UTC
(In reply to comment #3)
> Hi..
> > Can you please install Crash Reporter from the SDK Tools repository in order 
> > to send coredumps directly to Nokia?
> 
> I tried to install it but it is not installed.. some packages are missing..
> But there is someone who test it on the LEAKED new version and said that it
> works...
>
Everything about the leaked version is invalid unless it was released by Nokia,
which it wasn't :) 
> 
> 
> 
> (In reply to comment #2)
> > The users who created the translations know about the bug.
> > 
> > Right now I'm not sure who even made the translations, you say you made them,
> > yet you were never mentioned when I packaged it.
> > Anyways, this isn't a Maemo bug, but rather a bug in the user-made
> > localization.
> > The name (ar_SA) is also a known bug in the translations, again I never took
> > part in the translation but it's a bug in the .po files.
> > 
> > I'll leave the decision of what to do with this bug to Andre.
> > 
> 
> For the translation i started it but the one who give you the files complete
> the translation and made the most of works..
> For this bug it is not from .po files i tried the english one with ar_SA and it
> crashed also... so the problem is in the localizition sitting..
> I think there is conflict between region sitting and the language one...
> 

Well no one mentioned you helped at all.
Since the strings are in the .po files my point stands, the problem is with the
(translated) .po files.

Again I'll leave this to Andre to decide.
Region and localization can be different.
Comment 5 Andre Klapper maemo.org 2010-05-04 18:53:36 UTC
As written before:

> 1. when open the calender and try to add task it crashed..
> 2. when open the clock and try to edit the clock also it crashed..

Please install Crash Reporter from the SDK Tools repository in order to send
coredumps directly to Nokia.
See http://wiki.maemo.org/Extras-testing#Tools_for_testers for a how-to.
If you are offered to add a comment for sending the coredump file, please
mention this bug number (like "see bugs.maemo.org bug number xxxx").
Also, a filename will be displayed after uploading the coredump.
Please add the name of that file here in the bug report.
Comment 6 Andre Klapper maemo.org 2010-05-04 19:24:53 UTC
(In reply to comment #0)
> 1. when open the calender and try to add task it crashed..
> 2. when open the clock and try to edit the clock also it crashed..

Tried this in a newer internal version which will become PR1.2 and I could not
reproduce any of these crashes.
I guess the calendar crash was fixed by
https://bugs.maemo.org/show_bug.cgi?id=8889 .

Once that the next public release is out for public and you can still reproduce
this please provide *exact* steps, click by click. These original instructions
were too vague.